Bug 1638435

Summary: Unable to login using Red Hat Access plugin to list/open support cases through Satellite 6 webui
Product: Red Hat Satellite Reporter: Ashish Humbe <ahumbe>
Component: RH Cloud - InsightsAssignee: Marek Hulan <mhulan>
Status: CLOSED ERRATA QA Contact: jcallaha
Severity: high Docs Contact:
Priority: high    
Version: 6.4CC: jnewton, mhulan, mmccune, shisingh, zhunting
Target Milestone: 6.4.2Keywords: Regression, Triaged
Target Release: Unused   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: rubygem-redhat_access-2.2.0,tfm-rubygem-redhat_access-2.2.0-2 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-02-13 19:08:20 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1638263    
Bug Blocks:    
Attachments:
Description Flags
verification screenshot none

Description Ashish Humbe 2018-10-11 14:44:32 UTC
Description of problem:

When we login to Red Hat Access plugin through satellite 6 webui to manage support cases, it fails with error "Username or password was invalid". 

Here is the detailed traceback in logs: 

2018-10-11T09:04:11 [I|app|] Started GET "/redhat_access/strata/rs/users/current?redhat_client=foreman_plugin_satellite_2.1.6" for 10.76.1.176 at 2018-10-11 09:04:11 +0530
2018-10-11T09:04:11 [I|app|6e917] Processing by RedhatAccess::Api::StrataProxyController#call as application/vnd.redhat.user+json
2018-10-11T09:04:11 [I|app|6e917]   Parameters: {"redhat_client"=>"foreman_plugin_satellite_2.1.6", "path"=>"rs/users/current"}
2018-10-11T09:04:11 [I|app|6e917] Current user: admin (administrator)
2018-10-11T09:04:11 [W|app|6e917] Action failed
NameError: undefined local variable or method `env' for #<RedhatAccess::Api::StrataProxyController:0x000000000a5d82e8>
/opt/theforeman/tfm/root/usr/share/gems/gems/redhat_access-2.1.6/app/controllers/redhat_access/api/strata_proxy_controller.rb:66:in `get_api_client'
/opt/theforeman/tfm/root/usr/share/gems/gems/redhat_access-2.1.6/app/controllers/redhat_access/api/strata_proxy_controller.rb:45:in `call'
/opt/theforeman/tfm-ror51/root/usr/share/gems/gems/actionpack-5.1.6/lib/action_controller/metal/basic_implicit_render.rb:4:in `send_action'
/opt/theforeman/tfm-ror51/root/usr/share/gems/gems/actionpack-5.1.6/lib/abstract_controller/base.rb:186:in `process_action'
/opt/theforeman/tfm-ror51/root/usr/share/gems/gems/actionpack-5.1.6/lib/action_controller/metal/rendering.rb:30:in `process_action'
/opt/theforeman/tfm-ror51/root/usr/share/gems/gems/actionpack-5.1.6/lib/abstract_controller/callbacks.rb:20:in `block in process_action'
/opt/theforeman/tfm-ror51/root/usr/share/gems/gems/activesupport-5.1.6/lib/active_support/callbacks.rb:108:in `block in run_callbacks'
/usr/share/foreman/app/controllers/concerns/application_shared.rb:15:in `set_timezone'
/opt/theforeman/tfm-ror51/root/usr/share/gems/gems/activesupport-5.1.6/lib/active_support/callbacks.rb:117:in `block in run_callbacks'
/usr/share/foreman/app/models/concerns/foreman/thread_session.rb:32:in `clear_thread'
/opt/theforeman/tfm-ror51/root/usr/share/gems/gems/activesupport-5.1.6/lib/active_support/callbacks.rb:117:in `block in run_callbacks'
/usr/share/foreman/app/controllers/concerns/foreman/controller/topbar_sweeper.rb:12:in `set_topbar_sweeper_controller'
/opt/theforeman/tfm-ror51/root/usr/share/gems/gems/activesupport-5.1.6/lib/active_support/callbacks.rb:117:in `block in run_callbacks'
/opt/theforeman/tfm/root/usr/share/gems/gems/audited-4.7.0/lib/audited/sweeper.rb:14:in `around'
/opt/theforeman/tfm-ror51/root/usr/share/gems/gems/activesupport-5.1.6/lib/active_support/callbacks.rb:117:in `block in run_callbacks'
..
.
.
.
/usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler/thread_handler.rb:108:in `main_loop'
/usr/share/gems/gems/passenger-4.0.18/lib/phusion_passenger/request_handler.rb:441:in `block (3 levels) in start_threads'
/opt/theforeman/tfm/root/usr/share/gems/gems/logging-2.2.2/lib/logging/diagnostic_context.rb:474:in `block in create_with_logging_context'
2018-10-11T09:04:11 [I|app|6e917] Completed 500 Internal Server Error in 83ms (ActiveRecord: 1.5ms)

Version-Release number of selected component (if applicable):
Satellite 6.4 

How reproducible:
Always

Steps to Reproduce:
1. Login to Satellite 6.4, apply patch mentioned in the bz - https://bugzilla.redhat.com/show_bug.cgi?id=1638263
2. Navigate to "Access" -> "My Cases"
3. Enter Red Hat customer portal login details. 
4. Even if we enter correct login details, it back with mentioned error in the backend.

Actual results:
Unable to login using Red Hat Access plugin to manage support cases. 

Expected results:
We should be able to login and manage support cases from Satellite 6 webui.

Additional info:

Comment 7 jcallaha 2019-01-23 15:05:25 UTC
Verified in Satellite 6.4.2 snap 1

The plugin now lets you successfully log in to the portal account, so you can perform case management actions.

See attached screenshot for verification.

Comment 8 jcallaha 2019-01-23 15:05:38 UTC
Created attachment 1522713 [details]
verification screenshot

Comment 10 errata-xmlrpc 2019-02-13 19:08:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0345