Bug 1638263 - Red Hat Access menu is no longer displayed
Summary: Red Hat Access menu is no longer displayed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: RH Cloud - Insights
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: 6.4.2
Assignee: Marek Hulan
QA Contact: jcallaha
URL:
Whiteboard:
: 1638176 (view as bug list)
Depends On:
Blocks: 1638435
TreeView+ depends on / blocked
 
Reported: 2018-10-11 08:44 UTC by Marek Hulan
Modified: 2019-10-30 19:28 UTC (History)
9 users (show)

Fixed In Version: tfm-rubygem-redhat_access-2.2.0-2
Doc Type: Known Issue
Doc Text:
The change in navigation caused the Red Hat Access menu to no loner display. This issue will be fixed in an upcoming release.
Clone Of:
Environment:
Last Closed: 2019-02-13 19:08:20 UTC
Target Upstream Version:


Attachments (Terms of Use)
verification screenshot (120.19 KB, image/png)
2019-01-23 15:03 UTC, jcallaha
no flags Details


Links
System ID Priority Status Summary Last Updated
Github redhataccess foreman-plugin pull 27 None None None 2018-10-11 11:04:17 UTC
Red Hat Bugzilla 1619767 None None None 2019-08-01 12:24:44 UTC
Red Hat Knowledge Base (Solution) 3915491 Customize or extend None Where is Red Hat Access menu tab on Red Hat Satellite 6.4? 2019-02-16 14:59:38 UTC
Red Hat Product Errata RHBA-2019:0345 None None None 2019-02-13 19:08:25 UTC

Internal Links: 1619767

Description Marek Hulan 2018-10-11 08:44:08 UTC
Description of problem:

After vertical navigation change, the Red Hat Access menu is no longer displayed.

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1. log in to UI

Actual results:

see there's not Red Hat Access menu

Expected results:

There should be menu, after vertical navigation refactoring, it should live as separate category probably just after insights.

Additional info:

Comment 1 Marek Hulan 2018-10-11 08:54:35 UTC
*** Bug 1638176 has been marked as a duplicate of this bug. ***

Comment 3 Marek Hulan 2018-10-11 11:02:25 UTC
See a proposed new menu position and layout at https://github.com/redhataccess/foreman-plugin/pull/27

Comment 6 Ashish Humbe 2018-10-11 14:47:07 UTC
After applying mentioned code changes we can now list "Access" menu in vertical navigation but login to the customer portal when we click on "My Cases" does not work.

Created separate bz for the same: 

https://bugzilla.redhat.com/show_bug.cgi?id=1638435

Comment 8 jcallaha 2019-01-23 15:03:35 UTC
Verified in Satellite 6.4.2 Snap 1.

The menu items are not only visible, but we are also able to login to the plugin. 

See attached screenshot for verification.

Comment 9 jcallaha 2019-01-23 15:03:54 UTC
Created attachment 1522712 [details]
verification screenshot

Comment 11 errata-xmlrpc 2019-02-13 19:08:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0345


Note You need to log in before you can comment on or make changes to this bug.