Bug 164389

Summary: ant needs to obsolete ant-jmf
Product: [Fedora] Fedora Reporter: Dennis Gilmore <dennis>
Component: antAssignee: Deepak Bhole <dbhole>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: rawhideCC: katzj
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: 1.6.5-1jpp_9fc Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-06-07 19:38:24 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Dennis Gilmore 2005-07-27 16:11:15 UTC
Description of problem:
ant-apache-bsf needs to absolete ant-bsf

yum update of rawhide fails with Error: Missing Dependency: ant =
0:1.6.2-3jpp_10fc is needed by package ant-jmf

a look in rawhide shows no ant-bsf  anymore but an ant-apache-bsf  manuall
removal of ant-bsf  allows update to proced.  correct procedure is to put an
obsoletes  in the spec file  so update happen smoothly.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Vadim Nasardinov 2005-08-01 20:50:01 UTC
Are you sure that you mean "ant-bsf" and not "ant-jmf"?

Your reported error message says:

 Missing Dependency: ant =0:1.6.2-3jpp_10fc is needed by package ant-jmf

The error message is correct.  The "jmf" subpackage of "ant" has been
recently removed.  This prevents the upgrade of ant.  That's a bug
which will be fixed.  I just want to figure out whether or not you've
run into something else entirely.

To help me figure this out, can you confirm that what you manually
removed was "ant-BSF" rather than "ant-JMF"?  There has never been an
"ant-bsf" package to my knowledge.


Comment 2 Vadim Nasardinov 2005-08-02 17:31:43 UTC
*** Bug 164786 has been marked as a duplicate of this bug. ***

Comment 3 Vadim Nasardinov 2005-08-02 17:35:18 UTC
We never shipped "ant-bsf".

I'm changing the summary from

  ant-apache-bsf needs to obsolete ant-bsf

to
  ant needs to obsolete ant-jmf


See bug 164786 comment #2.


Comment 4 Dennis Gilmore 2005-08-03 00:32:22 UTC
Yes sorry i meant ant-jmf  i messed up when i after removing ant-jmf  yum  
installed ant-apache-bsf  

Comment 5 Deepak Bhole 2006-06-07 19:38:24 UTC
Has already been fixed in 1.6.5-1jpp_9fc.