Bug 164786 - ant-jmf needs to be obsoleted
ant-jmf needs to be obsoleted
Status: CLOSED DUPLICATE of bug 164389
Product: Fedora
Classification: Fedora
Component: ant (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Vadim Nasardinov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-01 09:16 EDT by Jeremy Katz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-02 13:31:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2005-08-01 09:16:27 EDT
If ant-jmf is going away, something should probably obsolete it.  Filing against
ant as I have no clue what the proper thing to do the obsoleting is.
Comment 1 Vadim Nasardinov 2005-08-01 15:50:45 EDT
Jeremy,

Since I nominally own the "ant" package, I'd like to understand the
failure mode a little better.  Gary removed the "jmf" subpackage of
"ant" on July 18 (cvs diff -c -r1.53 -r1.54 devel/ant.spec).  As you
point out, nothing currently obsoletes it.  Under what specific
circumstances does this lack of "Obsoletes" lead to problems?  Is this
related to bug 164389?

Thanks,
Vadim
Comment 2 Jeremy Katz 2005-08-01 16:01:06 EDT
ant-jmf depends on an explicit version of ant which no longer exists.  So trying
to do an update will fail as that package is then left with broken dependencies.
If it's just going away, it probably makes sense to just have the main ant
package obsolete it (since that's where the requires is)

And it's only vaguely related to the ant-bsf case -- that's much clearer in that
ant-apache-bsf provides the same functionality that used to be in the ant-bsf
package and thus, it should obsolete (and possibly also provide for old packages
which depended on the old package name) ant-bsf.
Comment 3 Vadim Nasardinov 2005-08-02 13:31:30 EDT
I'm marking this as a duplicate of bug 164389.  The initial report for
164389 is a little confusing, but upon careful reading it turns out to
be the same bug.

*** This bug has been marked as a duplicate of 164389 ***

Note You need to log in before you can comment on or make changes to this bug.