Bug 164389 - ant needs to obsolete ant-jmf
ant needs to obsolete ant-jmf
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ant (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Deepak Bhole
:
: 164786 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-27 12:11 EDT by Dennis Gilmore
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.6.5-1jpp_9fc
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-07 15:38:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2005-07-27 12:11:15 EDT
Description of problem:
ant-apache-bsf needs to absolete ant-bsf

yum update of rawhide fails with Error: Missing Dependency: ant =
0:1.6.2-3jpp_10fc is needed by package ant-jmf

a look in rawhide shows no ant-bsf  anymore but an ant-apache-bsf  manuall
removal of ant-bsf  allows update to proced.  correct procedure is to put an
obsoletes  in the spec file  so update happen smoothly.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Vadim Nasardinov 2005-08-01 16:50:01 EDT
Are you sure that you mean "ant-bsf" and not "ant-jmf"?

Your reported error message says:

 Missing Dependency: ant =0:1.6.2-3jpp_10fc is needed by package ant-jmf

The error message is correct.  The "jmf" subpackage of "ant" has been
recently removed.  This prevents the upgrade of ant.  That's a bug
which will be fixed.  I just want to figure out whether or not you've
run into something else entirely.

To help me figure this out, can you confirm that what you manually
removed was "ant-BSF" rather than "ant-JMF"?  There has never been an
"ant-bsf" package to my knowledge.
Comment 2 Vadim Nasardinov 2005-08-02 13:31:43 EDT
*** Bug 164786 has been marked as a duplicate of this bug. ***
Comment 3 Vadim Nasardinov 2005-08-02 13:35:18 EDT
We never shipped "ant-bsf".

I'm changing the summary from

  ant-apache-bsf needs to obsolete ant-bsf

to
  ant needs to obsolete ant-jmf


See bug 164786 comment #2.
Comment 4 Dennis Gilmore 2005-08-02 20:32:22 EDT
Yes sorry i meant ant-jmf  i messed up when i after removing ant-jmf  yum  
installed ant-apache-bsf  
Comment 5 Deepak Bhole 2006-06-07 15:38:24 EDT
Has already been fixed in 1.6.5-1jpp_9fc.

Note You need to log in before you can comment on or make changes to this bug.