Bug 1684970

Summary: libiw no longer linked to libm
Product: [Fedora] Fedora Reporter: Jens Petersen <petersen>
Component: wireless-toolsAssignee: Lubomir Rintel <lkundrak>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 30CC: dcbw, linville, lkundrak, moceap, redhat-bugzilla
Target Milestone: ---Keywords: Regression
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: wireless-tools-29-25.fc30 wireless-tools-29-25.fc31 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-03-09 20:54:37 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jens Petersen 2019-03-04 03:28:51 UTC
Description of problem:
It seems in F30 libiw.so is no longer linked to libm.so.
Not sure if this change is intended/expected, so thought
I would just report it anyway (this broke the build of iwlib in
xmobar for example).

Version-Release number of selected component (if applicable):
wireless-tools-devel-29-22.fc30.x86_64

Comment 1 Jens Petersen 2019-03-04 04:05:52 UTC
I had to manually add libm linking to xmobar too.

Comment 2 Nathan G. Grennan 2019-05-27 19:34:15 UTC
I had the same problem with reaver needing wireless-tools on F30. Downgrading to the F29 rpms worked.

Comparing the source rpms, it looks like pretty much nothing changed. The code is the same, the patch is the same, and the spec file is almost identical. So the difference seems to be in the build tools.

Comment 3 Fedora Update System 2020-02-23 12:33:32 UTC
FEDORA-2020-a334dc624d has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-a334dc624d

Comment 4 Jens Petersen 2020-02-23 12:36:07 UTC
This is basically a duplicate of newer bug 1732645.

Comment 5 Fedora Update System 2020-02-24 02:07:40 UTC
wireless-tools-29-25.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-5d27f4c3f9

Comment 6 Fedora Update System 2020-02-24 02:08:40 UTC
wireless-tools-29-25.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-a334dc624d

Comment 7 Fedora Update System 2020-03-09 20:54:37 UTC
wireless-tools-29-25.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2020-03-11 22:45:45 UTC
wireless-tools-29-25.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.