Bug 1734525

Summary: overcloud deploy fails with ou must add a [grafana-server] group and add at least one node
Product: Red Hat OpenStack Reporter: Alistair Tonner <atonner>
Component: openstack-tripleo-heat-templatesAssignee: John Fulton <johfulto>
Status: CLOSED ERRATA QA Contact: Filip Hubík <fhubik>
Severity: medium Docs Contact:
Priority: medium    
Version: 15.0 (Stein)CC: fhubik, gcharot, gfidente, johfulto, mburns, mcornea, psedlak, sasha, tbarron
Target Milestone: rcKeywords: Triaged
Target Release: 15.0 (Stein)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-10.6.1-0.20190731170522.a1c15da.el8ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2019-09-21 11:24:21 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Alistair Tonner 2019-07-30 19:10:04 UTC
Description of problem:

   OSP 15 deployment fails in overcloud deploy step and emits:

       "fatal: [controller-0]: FAILED! => changed=false ",
        "  msg: you must add a [grafana-server] group and add at least one node.",
        "fatal: [controller-1]: FAILED! => changed=false ",
        "fatal: [controller-2]: FAILED! => changed=false ",
        "fatal: [ceph-0]: FAILED! => changed=false ",
        "fatal: [ceph-1]: FAILED! => changed=false ",
        "fatal: [ceph-2]: FAILED! => changed=false ",
        "fatal: [compute-0]: FAILED! => changed=false ",



Version-Release number of selected component (if applicable):

# rhos-release -L
Installed repositories (rhel-8.0):
  15
  ceph-4
  ceph-osd-4
  rhel-8.0

RHOS_TRUNK-15.0-RHEL-8-20190729.n.0

dnf list installed |grep ceph
ceph-ansible.noarch                               4.0.0-0.1.rc13.el8cp                                     @rhelosp-ceph-4.0-tools-pending
librados2.x86_64                                  2:14.2.2-16.ga7a380a.1.el8cp                             @rhelosp-ceph-4.0-mon-pending  
librbd1.x86_64                                    2:14.2.2-16.ga7a380a.1.el8cp                             @rhelosp-ceph-4.0-mon-pending  
lttng-ust.x86_64                                  2.8.1-9.1.el8cp                                          @rhelosp-ceph-4.0-mon-pending  
puppet-ceph.noarch                                3.0.1-0.20190612030451.e157497.el8ost                    @rhelosp-15.0                  


How reproducible:

Consistent:

Steps to Reproduce:
1. Deploy standard OSP15 with 
    ControllerCount: 3
    OvercloudControlFlavor: controller
    ComputeCount: 1
    OvercloudComputeFlavor: compute
    CephStorageCount: 3
    OvercloudCephStorageFlavor: ceph

Actual results:

"fatal: [controller-0]: FAILED! => changed=false ",
        "  msg: you must add a [grafana-server] group and add at least one

Expected results:

   Overcloud deploys successfully

Additional info:

Comment 1 John Fulton 2019-07-30 19:24:07 UTC
1. Root Cause:

ceph-ansible 4.0.0rc13 enables ceph-dashboard by default but the earlier version didn't:

 https://github.com/ceph/ceph-ansible/commit/93826e061d3d025fa631d726ada1c7a7d77c12b1


2. Workaround:
Deploy with the following:

parameter_defaults:
  CephAnsibleExtraConfig:
    dashboard_enabled: False

3. Proposed fix:
Fix will be to make dashboard_enabled=False in THT (overriding the new default in ceph-ansible).

Comment 2 John Fulton 2019-07-30 19:28:36 UTC
Director will deploy ceph dashboard in osp16d as per RFE bz 1626260

Comment 6 John Fulton 2019-07-31 12:08:04 UTC
*** Bug 1734761 has been marked as a duplicate of this bug. ***

Comment 10 Filip Hubík 2019-08-06 11:17:45 UTC
Verified on RHOS_TRUNK-15.0-RHEL-8-20190729.n.0 content with openstack-tripleo-heat-templates-10.6.1-0.20190731170522.a1c15da pre-installed on UC before OC deployment.

Comment 13 errata-xmlrpc 2019-09-21 11:24:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811