Bug 1626260 - [RFE] Support deployment of ceph-dashboard with RHCS4 via director
Summary: [RFE] Support deployment of ceph-dashboard with RHCS4 via director
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 16.0 (Train)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M3
: 16.0
Assignee: fpantano
QA Contact: Yogev Rabl
URL:
Whiteboard:
: 1475556 1724198 (view as bug list)
Depends On: 1785692
Blocks: 1475550 1475555 1595325 1702811 1715964 1765055 1790754
TreeView+ depends on / blocked
 
Reported: 2018-09-06 21:16 UTC by John Fulton
Modified: 2020-04-01 10:27 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-heat-templates-11.3.1-0.20191126041653.414d4d9.el8ost.noarch.rpm
Doc Type: Technology Preview
Doc Text:
In Red Hat OpenStack Platform 16.0, a technology preview has been added to Red Hat OpenStack director that automatically deploys the Red Hat Ceph Storage dashboard. As with the other Red Hat Ceph Storage components, operators can now include a ceph-dashboard template containing all the parameters and resources needed to enable the dashboard when they run the ceph-ansible playbook.
Clone Of:
: 1790754 (view as bug list)
Environment:
Last Closed: 2020-01-30 13:39:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 666578 'None' MERGED Add dashboard component as new ceph composable service. 2020-04-01 20:06:39 UTC
OpenStack gerrit 667538 'None' MERGED Add new images for ceph dashboard composable service. 2020-04-01 20:06:38 UTC
OpenStack gerrit 672536 'None' MERGED Add CephGrafanaNetwork to the list of the services 2020-04-01 20:06:37 UTC
OpenStack gerrit 672538 'None' MERGED Add ceph grafana dashboard endpoint to haproxy 2020-04-01 20:06:37 UTC
OpenStack gerrit 672705 'None' MERGED Enable ceph dashboard on scenario001 2020-04-01 20:06:37 UTC
OpenStack gerrit 674553 'None' MERGED Ceph grafana service certificate request 2020-04-01 20:06:37 UTC
OpenStack gerrit 674556 'None' MERGED Add the certificate specs in ceph_grafana composable service 2020-04-01 20:06:37 UTC
OpenStack gerrit 676395 'None' MERGED Add certmonger-grafana-refresh script 2020-04-01 20:06:37 UTC
OpenStack gerrit 677705 'None' MERGED Change ceph dashboard service name to meet puppet requirements 2020-04-01 20:06:37 UTC
OpenStack gerrit 677708 'None' MERGED Replace ceph_grafana-server with ceph_grafana 2020-04-01 20:06:37 UTC
OpenStack gerrit 678793 'None' MERGED Add Ceph Dashboard deployment section 2020-04-01 20:06:37 UTC

Internal Links: 1734525

Description John Fulton 2018-09-06 21:16:45 UTC
It's possible to get Ceph Metrics working with RHOSP by running it as an instance in the overcloud [1] and it should be possible to get Ceph Dashboard working with RHOSP by modifying the same procedure to use playbooks which deploy Ceph Dashboard. 

However, it would be better if the process to get Ceph Dashboard working with RHOSP didn't require the user to take as many manual steps in the overcloud. Ideally, users could treat CephMetrics as a composable service the same way they treat other composable services. In other words, if OSPd's roles_data.yaml had OS::TripleO::Services::CephDashboard the same way it has OS::TripleO::Services::CephOSD. 

This is an RFE to enable the improved scenario described above and it depends on leveraging new roles in ceph-ansible which would enable it to deploy ceph-dashboard as tracked in Ceph BZ1563009.

[1] https://github.com/ceph/cephmetrics-osp

Comment 1 John Fulton 2019-07-03 13:16:02 UTC
*** Bug 1724198 has been marked as a duplicate of this bug. ***

Comment 5 Gregory Charot 2019-07-25 16:06:12 UTC
*** Bug 1475556 has been marked as a duplicate of this bug. ***

Comment 32 Gregory Charot 2020-01-30 13:39:00 UTC
Due to some unresolved dependencies in RHCSv4, this RFE does not meet the Tech Preview quality criterias and therefore closed deferred.

The new RFE to track full support is https://bugzilla.redhat.com/show_bug.cgi?id=1790754

Target is OSP 16.0.2 assuming the RHCS dependencies are solved by that time.

To customers and partners: Please reach out to your account/partner team for more details.
To RH internal: Please reach out to RHOS team for more details.


Note You need to log in before you can comment on or make changes to this bug.