Bug 1742

Summary: lilo can fail to install.
Product: [Retired] Red Hat Linux Reporter: Jeremiah Johnson <jjohnson>
Component: installerAssignee: Matt Wilson <msw>
Status: CLOSED CURRENTRELEASE QA Contact:
Severity: medium Docs Contact:
Priority: medium    
Version: 6.0CC: 2, wtlovely
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-09-25 03:47:49 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jeremiah Johnson 1999-03-24 17:01:01 UTC
If you "make" a msdos partition with diskdruid during
installation, lilo will fail to install. This is because the
device does not have a valid filesystem. I reported this to
dale before beta testing for 5.6.x+ when I found it while
installing RH 5.2, he said that if it appeared in the beta's
to let you know. So now I am.

Comment 1 Preston Brown 1999-03-26 21:33:59 UTC
this one looks nasty Matt.

Comment 2 Matt Wilson 1999-04-01 05:51:59 UTC
*** Bug 1334 has been marked as a duplicate of this bug. ***

Lilo warnings are not shown to the user if they occur during
installation.  As some lilo warnings indicate a serious
problem you can easily get caught out and lock up your
machine.

------- Additional Comments From gafton@redhat.com  03/18/99 19:40 -------
assigned to msw

Comment 3 Matt Wilson 1999-04-01 05:58:59 UTC
*** Bug 1451 has been marked as a duplicate of this bug. ***

At the end of the install for 5.2 the user is asked where
lilo should be installed.  I selected Master Boot Record.
The write of the loader to the Boot Record failed.  I tried
and tried to install lilo via the normal install.
Eventually I found that the installer had written a
lilo.conf file that was too big to be written to the
boot sector.  So I removed some entries and then ran lilo.
I would think that a safeguard would be in place to
keep lilo.conf from growing to be too big.

------- Additional Comments From msw@redhat.com  04/01/99 00:57 -------
it's not that the lilo entries were too big - it's probably that there
was an entry for "dos" in the lilo configuration pointing at a dos
filesystem that didn't have a valid boot block on it.

Comment 4 Bill Nottingham 1999-09-25 03:47:59 UTC
*** This bug has been marked as a duplicate of 4 ***