Bug 1742913

Summary: biber-2.14 is available
Product: [Fedora] Fedora Reporter: Upstream Release Monitoring <upstream-release-monitoring>
Component: biberAssignee: Colin Macdonald <cbm>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: rawhideCC: cbm, jnovy, mefoster, orion, perl-devel, ppisar, spot
Target Milestone: ---Keywords: FutureFeature, Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: biber-2.14-1.fc33 Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-20 03:45:46 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Attachments:
Description Flags
[patch] Update to 2.13 (#1742913) none

Description Upstream Release Monitoring 2019-08-17 14:47:45 UTC
Latest upstream release: 2.13
Current version/release in rawhide: 2.11-6.fc31
URL: http://biblatex-biber.sourceforge.net/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/6443/

Comment 1 Upstream Release Monitoring 2019-08-17 14:47:49 UTC
Created attachment 1605296 [details]
[patch] Update to 2.13 (#1742913)

Comment 2 Upstream Release Monitoring 2019-08-17 14:50:58 UTC
the-new-hotness/release-monitoring.org@FEDORAPROJECT.ORG's scratch build of biber-2.13-1.fc29.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=37100542

Comment 3 Colin Macdonald 2019-11-17 23:47:33 UTC
as usual this won't happen until texlive-biblatex hits 3.13.

Comment 4 Upstream Release Monitoring 2019-12-01 16:55:43 UTC
Latest upstream release: 2.14
Current version/release in rawhide: 2.12-1.fc32
URL: http://biblatex-biber.sourceforge.net/

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/6443/

Comment 5 Upstream Release Monitoring 2019-12-01 16:55:48 UTC
An unexpected error occurred while creating the scratch build and has been automatically reported. Sorry!

Comment 6 Petr Pisar 2020-05-15 10:38:42 UTC
Fedora 33 just received texlive-biblatex-svn53063-20.fc33.noarch with /usr/share/texlive/texmf-dist/bibtex/bst/biblatex/biblatex.bst file:

FUNCTION {initialize} {
  "$Revision: 3.13 $"

For your information, a test in current Fedora's biber fails <https://koschei.fedoraproject.org/build/8342988>.

Comment 7 Colin Macdonald 2020-05-16 01:54:07 UTC
Thanks!  @spot and @orion have done a lot.  There is a failing test I'm looking at now:

```
t/utils.t ................. 
1..82
ok 1 - File location - 1
ok 2 - File location - 2
ok 3 - File location - 3
ERROR - Cannot find 'plain.tex'!
# Looks like your test exited with 2 just after 3.
Dubious, test returned 2 (wstat 512, 0x200)
Failed 79/82 subtests 
```

Comment 8 Colin Macdonald 2020-05-16 02:02:03 UTC
The test looks for plain.tex.

On Fedora 32:

$ kpsewhich plain.tex
/usr/share/texlive/texmf-dist/tex/plain/base/plain.tex


On Rawhide, it doesn't return anything, even thought that file exists:


$ kpsewhich plain.tex
$
$ ls /usr/share/texlive/texmf-dist/tex/plain/base/plain.tex
/usr/share/texlive/texmf-dist/tex/plain/base/plain.tex


Tom has something changed after the texlive upgrade?

Comment 9 Orion Poplawski 2020-05-16 02:06:09 UTC
Yeah, I have a fix for this coming shortly - https://bugzilla.redhat.com/show_bug.cgi?id=1836464

Comment 11 Colin Macdonald 2020-05-16 02:20:22 UTC
Maybe this is no longer relevant, but I tried to post this and got a midair collision:

On rawhide-test.fedorainfracloud.org, I tried to reinstall kpathsea and got some errors:

$ sudo dnf reinstall texlive-kpathsea

Downloading Packages:
texlive-kpathsea-20200327-2.fc33.x86_64.rpm               6.6 MB/s | 1.1 MB     00:00    
------------------------------------------------------------------------------------------
Total                                                     2.0 MB/s | 1.1 MB     00:00     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                                  1/1 
  Reinstalling     : texlive-kpathsea-7:20200327-2.fc33.x86_64                        1/2 
  Cleanup          : texlive-kpathsea-7:20200327-2.fc33.x86_64                        2/2 
  Running scriptlet: texlive-kpathsea-7:20200327-2.fc33.x86_64                        2/2 
cat: /usr/share/texlive/texmf-dist/web2c/fmtutil-hdr.cnf: No such file or directory
warning: %triggerpostun(texlive-kpathsea-7:20200327-2.fc33.x86_64) scriptlet failed, exit status 1

Error in <unknown> scriptlet in rpm package texlive-kpathsea
/var/tmp/rpm-tmp.2wk3Qz: line 11: /usr/bin/updmap-sys: No such file or directory

  Verifying        : texlive-kpathsea-7:20200327-2.fc33.x86_64                        1/2 
  Verifying        : texlive-kpathsea-7:20200327-2.fc33.x86_64                        2/2 

Reinstalled:
  texlive-kpathsea-7:20200327-2.fc33.x86_64                                               

Complete!

Comment 12 Orion Poplawski 2020-05-19 03:15:12 UTC
Yeah, that's at least one of the things hopefully fixed in the latest build.  We are still seeing very strange things in koji though that we have so far been unable to diagnose.