Bug 1775530

Summary: Add the AWS cli to the OSP CI image
Product: OpenShift Container Platform Reporter: Pierre Prinetti <pprinett>
Component: InstallerAssignee: Pierre Prinetti <pprinett>
Installer sub component: OpenShift on OpenStack QA Contact: David Sanz <dsanzmor>
Status: CLOSED ERRATA Docs Contact:
Severity: high    
Priority: unspecified    
Version: 4.2.0   
Target Milestone: ---   
Target Release: 4.3.0   
Hardware: All   
OS: All   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
: 1775531 (view as bug list) Environment:
Last Closed: 2020-04-30 01:28:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1775531    

Description Pierre Prinetti 2019-11-22 08:24:22 UTC
Description of problem:

OpenShift on OpenStack CI test images need an AWS client in order to attach domain names to the API and Ingress floating IPs.

Additional info:
The issue is fixed on the `master` 4.3 branch already. This BZ exists for backporting to 4.2.z and make the 4.2 tests run in the CI.


ref: https://github.com/openshift/installer/pull/2663

Comment 1 Pierre Prinetti 2019-11-22 08:25:48 UTC
This is implemented in https://github.com/openshift/installer/pull/2663

Comment 4 errata-xmlrpc 2020-04-30 01:28:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1529