Bug 1775531 - Add the AWS cli to the OSP CI image
Summary: Add the AWS cli to the OSP CI image
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.0
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
: 4.2.z
Assignee: Pierre Prinetti
QA Contact: David Sanz
URL:
Whiteboard:
: 1776379 (view as bug list)
Depends On: 1775530
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-11-22 08:27 UTC by Pierre Prinetti
Modified: 2020-04-17 13:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1775530
Environment:
Last Closed: 2019-12-03 22:43:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift installer pull 2707 'None' closed Bug 1775531: images/openstack: add awscli to image 2020-04-28 21:38:26 UTC
Red Hat Bugzilla 1776379 'unspecified' 'CLOSED' 'ocp 4.2 failures because: "aws: command not found"' 2019-12-02 14:22:28 UTC
Red Hat Product Errata RHBA-2019:3953 None None None 2019-12-03 22:43:23 UTC

Description Pierre Prinetti 2019-11-22 08:27:15 UTC
+++ This bug was initially created as a clone of Bug #1775530 +++

Description of problem:

OpenShift on OpenStack CI test images need an AWS client in order to attach domain names to the API and Ingress floating IPs.

Additional info:
The issue is fixed on the `master` 4.3 branch already.


ref: https://github.com/openshift/installer/pull/2663

Comment 1 Lokesh Mandvekar 2019-11-25 15:36:24 UTC
This issue is affecting 4.2 as well. I filed Bug 1776379 for it.

Comment 3 Tomas Sedovic 2019-11-25 15:50:29 UTC
*** Bug 1776379 has been marked as a duplicate of this bug. ***

Comment 6 errata-xmlrpc 2019-12-03 22:43:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3953


Note You need to log in before you can comment on or make changes to this bug.