Bug 1775530 - Add the AWS cli to the OSP CI image
Summary: Add the AWS cli to the OSP CI image
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 4.2.0
Hardware: All
OS: All
unspecified
high
Target Milestone: ---
: 4.3.0
Assignee: Pierre Prinetti
QA Contact: David Sanz
URL:
Whiteboard:
Depends On:
Blocks: 1775531
TreeView+ depends on / blocked
 
Reported: 2019-11-22 08:24 UTC by Pierre Prinetti
Modified: 2020-04-30 01:28 UTC (History)
0 users

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1775531 (view as bug list)
Environment:
Last Closed: 2020-04-30 01:28:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift installer pull 2663 0 None closed OpenStack CI: add awscli to the CI image 2020-04-24 17:18:17 UTC
Red Hat Product Errata RHBA-2020:1529 0 None None None 2020-04-30 01:28:21 UTC

Description Pierre Prinetti 2019-11-22 08:24:22 UTC
Description of problem:

OpenShift on OpenStack CI test images need an AWS client in order to attach domain names to the API and Ingress floating IPs.

Additional info:
The issue is fixed on the `master` 4.3 branch already. This BZ exists for backporting to 4.2.z and make the 4.2 tests run in the CI.


ref: https://github.com/openshift/installer/pull/2663

Comment 1 Pierre Prinetti 2019-11-22 08:25:48 UTC
This is implemented in https://github.com/openshift/installer/pull/2663

Comment 4 errata-xmlrpc 2020-04-30 01:28:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1529


Note You need to log in before you can comment on or make changes to this bug.