Bug 1780736

Summary: OLM resources do not display status using an icon
Product: OpenShift Container Platform Reporter: Robb Hamilton <rhamilto>
Component: Management ConsoleAssignee: Samuel Padgett <spadgett>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: low Docs Contact:
Priority: unspecified    
Version: 4.3.0CC: aos-bugs, jokerman, spadgett, yanpzhan, yapei
Target Milestone: ---   
Target Release: 4.3.0   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1780629 Environment:
Version: 4.3.0-0.ci-2019-11-22-122829 Cluster ID: c4580144-6f59-47bf-a801-ada3c4082806 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36
Last Closed: 2020-01-23 11:17:47 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1780629    
Bug Blocks:    

Description Robb Hamilton 2019-12-06 18:39:14 UTC
+++ This bug was initially created as a clone of Bug #1780629 +++

Description of problem:  Operators, install plans, and operand resources display status, but do not make use of an icon alongside the status value (which is our pattern elsewhere).


Version-Release number of selected component (if applicable):  4.3


How reproducible:  Always


Steps to Reproduce:
1.  Visit Operator Details and view Status under ClusterServiceVersion Overview and note the absence of an icon beside status value.
2.  Visit Search and set the filter to Install Plan and note the absence of an icon beside status values.
3.  Visit Install Plan Details and note the absence of an icon beside status value.
4.  Visit Operand Details and note the absence of an icon beside status values.

Actual results:  Status display without an icon.


Expected results:  Status displays with an icon.


Additional info:

Comment 2 Yadan Pei 2019-12-09 06:53:23 UTC
PR #3711 is still open, move to MODIFIED

Comment 4 Samuel Padgett 2019-12-10 14:14:37 UTC
PR 3711 has merged, and we've opted to close PR 3739 since it's not required for the fix. Moving status back to MODIFIED.

Comment 6 Yanping Zhang 2019-12-11 05:44:49 UTC
Tested on ocp 4.3 with payload 4.3.0-0.nightly-2019-12-10-120829.
Install an operator in project, eg, "CouchBase" operator, check on the CSV detail page, there is icon beside the status text, go to the install plan page from "Subscription" tab, there is icon for status. Then create instance, check on the detail page of the instance, there is icon beside the status text, too.
The bug is fixed, so move it to Verified.

Comment 8 errata-xmlrpc 2020-01-23 11:17:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062