Bug 1780736 - OLM resources do not display status using an icon
Summary: OLM resources do not display status using an icon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.3.0
Assignee: Samuel Padgett
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1780629
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-12-06 18:39 UTC by Robb Hamilton
Modified: 2020-01-23 11:18 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1780629
Environment:
Version: 4.3.0-0.ci-2019-11-22-122829 Cluster ID: c4580144-6f59-47bf-a801-ada3c4082806 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36
Last Closed: 2020-01-23 11:17:47 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3711 'None' closed [release-4.3] Bug 1780736: Add `<Status>` to Operator resources 2020-02-05 10:02:21 UTC
Red Hat Product Errata RHBA-2020:0062 None None None 2020-01-23 11:18:08 UTC

Description Robb Hamilton 2019-12-06 18:39:14 UTC
+++ This bug was initially created as a clone of Bug #1780629 +++

Description of problem:  Operators, install plans, and operand resources display status, but do not make use of an icon alongside the status value (which is our pattern elsewhere).


Version-Release number of selected component (if applicable):  4.3


How reproducible:  Always


Steps to Reproduce:
1.  Visit Operator Details and view Status under ClusterServiceVersion Overview and note the absence of an icon beside status value.
2.  Visit Search and set the filter to Install Plan and note the absence of an icon beside status values.
3.  Visit Install Plan Details and note the absence of an icon beside status value.
4.  Visit Operand Details and note the absence of an icon beside status values.

Actual results:  Status display without an icon.


Expected results:  Status displays with an icon.


Additional info:

Comment 2 Yadan Pei 2019-12-09 06:53:23 UTC
PR #3711 is still open, move to MODIFIED

Comment 4 Samuel Padgett 2019-12-10 14:14:37 UTC
PR 3711 has merged, and we've opted to close PR 3739 since it's not required for the fix. Moving status back to MODIFIED.

Comment 6 Yanping Zhang 2019-12-11 05:44:49 UTC
Tested on ocp 4.3 with payload 4.3.0-0.nightly-2019-12-10-120829.
Install an operator in project, eg, "CouchBase" operator, check on the CSV detail page, there is icon beside the status text, go to the install plan page from "Subscription" tab, there is icon for status. Then create instance, check on the detail page of the instance, there is icon beside the status text, too.
The bug is fixed, so move it to Verified.

Comment 8 errata-xmlrpc 2020-01-23 11:17:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0062


Note You need to log in before you can comment on or make changes to this bug.