Bug 1780629 - OLM resources do not display status using an icon
Summary: OLM resources do not display status using an icon
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1780736
TreeView+ depends on / blocked
 
Reported: 2019-12-06 14:57 UTC by Robb Hamilton
Modified: 2020-05-04 11:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Some status values do not have an icon associated with them, so they display without an icon. Consequence: Some status values display with an icon and some do not. Fix: Define icons for status values that lack them. Result: All status values should now display with an icon.
Clone Of:
: 1780736 (view as bug list)
Environment:
Version: 4.3.0-0.ci-2019-11-22-122829 Cluster ID: c4580144-6f59-47bf-a801-ada3c4082806 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36
Last Closed: 2020-05-04 11:19:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 3707 'None' closed Bug 1780629: Add `<Status>` to Operator resources 2020-04-17 19:44:08 UTC
Github openshift console pull 3714 'None' closed Bug 1780629: Move `Created` case to existing `<SuccessStatus>` to avoid duplication 2020-04-17 19:44:09 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:19:37 UTC

Description Robb Hamilton 2019-12-06 14:57:57 UTC
Description of problem:  Operators, install plans, and operand resources display status, but do not make use of an icon alongside the status value (which is our pattern elsewhere).


Version-Release number of selected component (if applicable):  4.3


How reproducible:  Always


Steps to Reproduce:
1.  Visit Operator Details and view Status under ClusterServiceVersion Overview and note the absence of an icon beside status value.
2.  Visit Search and set the filter to Install Plan and note the absence of an icon beside status values.
3.  Visit Install Plan Details and note the absence of an icon beside status value.
4.  Visit Operand Details and note the absence of an icon beside status values.

Actual results:  Status display without an icon.


Expected results:  Status displays with an icon.


Additional info:

Comment 2 Yanping Zhang 2019-12-16 07:30:55 UTC
Tested on ocp 4.3 with payload version 4.4.0-0.nightly-2019-12-14-103510, installed "etcd" and "couchbase" operators in project, checked status on the CSV detailed page, there were correct icons beside status. Checked on install plan page, there were also status icon. And different statuses had corresponding icons.
The bug has been fixed, so move it to Verified.

Comment 4 errata-xmlrpc 2020-05-04 11:19:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.