Bug 1788188

Summary: kube-apiserver-operator metrics cannot be scraped in IPv6 cluster
Product: OpenShift Container Platform Reporter: Neelesh Agrawal <nagrawal>
Component: kube-apiserverAssignee: Michal Fojtik <mfojtik>
Status: CLOSED ERRATA QA Contact: Ke Wang <kewang>
Severity: high Docs Contact:
Priority: unspecified    
Version: 4.3.0CC: aos-bugs, mfojtik, nagrawal, pkrupa, scuppett, sttts, xxia
Target Milestone: ---   
Target Release: 4.3.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1788140 Environment:
Last Closed: 2020-06-03 03:30:41 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1788140    
Bug Blocks:    

Description Neelesh Agrawal 2020-01-06 16:18:50 UTC
+++ This bug was initially created as a clone of Bug #1788140 +++

Description of problem:
In IPv6 cluster metrics from kube-apiserver-operator cannot be scraped due to connection refused error

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-18-145749-ipv6.1

How reproducible:
Always

Steps to Reproduce:
1. Start a cluster
2. Go to prometheus UI -> targets (this needs to be done with port-forward, due to https://bugzilla.redhat.com/show_bug.cgi?id=1788135, cmd: "-n openshift-monitoring port-forward svc/prometheus-operated 9090")

Actual results:
`openshift-apiserver-operator/openshift-apiserver-operator/0` is DOWN


Expected results:
`openshift-apiserver-operator/openshift-apiserver-operator/0` is UP


Additional info:

--- Additional comment from Pawel Krupa on 2020-01-06 09:34:49 EST ---

It should be `openshift-kube-apiserver-operator/kube-apiserver-operator/0` instead of `openshift-apiserver-operator/openshift-apiserver-operator/0`.

--- Additional comment from Neelesh Agrawal on 2020-01-06 10:56:41 EST ---

Following BZ 1788135 and moving this to 4.4. Will clone for 4.3.z

Comment 4 Ke Wang 2020-05-28 02:44:01 UTC
Encountered difficulties in creating OCP IPV6 4.3 cluster.

Comment 7 errata-xmlrpc 2020-06-03 03:30:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2256