Bug 1788140 - kube-apiserver-operator metrics cannot be scraped in IPv6 cluster
Summary: kube-apiserver-operator metrics cannot be scraped in IPv6 cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.0
Assignee: Michal Fojtik
QA Contact: Ke Wang
URL:
Whiteboard:
Depends On:
Blocks: 1788188
TreeView+ depends on / blocked
 
Reported: 2020-01-06 14:28 UTC by Pawel Krupa
Modified: 2020-05-04 11:23 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1788188 1790430 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:22:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
must gather (18.92 MB, application/gzip)
2020-01-06 14:28 UTC, Pawel Krupa
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1788139 0 unspecified CLOSED Operator metrics cannot be scraped in IPv6 cluster 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:23:09 UTC

Internal Links: 1788151

Description Pawel Krupa 2020-01-06 14:28:02 UTC
Created attachment 1650123 [details]
must gather

Description of problem:
In IPv6 cluster metrics from kube-apiserver-operator cannot be scraped due to connection refused error

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-18-145749-ipv6.1

How reproducible:
Always

Steps to Reproduce:
1. Start a cluster
2. Go to prometheus UI -> targets (this needs to be done with port-forward, due to https://bugzilla.redhat.com/show_bug.cgi?id=1788135, cmd: "-n openshift-monitoring port-forward svc/prometheus-operated 9090")

Actual results:
`openshift-apiserver-operator/openshift-apiserver-operator/0` is DOWN


Expected results:
`openshift-apiserver-operator/openshift-apiserver-operator/0` is UP


Additional info:

Comment 1 Pawel Krupa 2020-01-06 14:34:49 UTC
It should be `openshift-kube-apiserver-operator/kube-apiserver-operator/0` instead of `openshift-apiserver-operator/openshift-apiserver-operator/0`.

Comment 5 Ke Wang 2020-03-24 10:04:51 UTC
Verified with OCP build ipv6 4.4.0-0.nightly-2020-03-23-010639, metrics  service of kube-apiserver  is up.
Go to prometheus UI -> menu(Status) -> Drop-down list(Targets), search keyword with “openshift-kube-apiserver-operator” in page,

openshift-kube-apiserver-operator/kube-apiserver-operator/0 (1/1 up):   
https://[fd01::1:68f4:caff:fe00:24]:8443/metrics   up  endpoint="https"   instance="[fd01::1:68f4:caff:fe00:24]:8443"  job="metrics"   namespace="openshift-kube-apiserver-operator"  pod="kube-apiserver-operator-6ffffbdb75-nj6dv"  service="metrics"

Comment 7 errata-xmlrpc 2020-05-04 11:22:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.