Bug 1788188 - kube-apiserver-operator metrics cannot be scraped in IPv6 cluster
Summary: kube-apiserver-operator metrics cannot be scraped in IPv6 cluster
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.z
Assignee: Michal Fojtik
QA Contact: Ke Wang
URL:
Whiteboard:
Depends On: 1788140
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-01-06 16:18 UTC by Neelesh Agrawal
Modified: 2020-06-03 03:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1788140
Environment:
Last Closed: 2020-06-03 03:30:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-kube-apiserver-operator pull 712 None closed Bug 1788188: [release-4.3] bump(*): vendor update 2020-05-27 02:49:38 UTC
Red Hat Product Errata RHBA-2020:2256 None None None 2020-06-03 03:31:00 UTC

Description Neelesh Agrawal 2020-01-06 16:18:50 UTC
+++ This bug was initially created as a clone of Bug #1788140 +++

Description of problem:
In IPv6 cluster metrics from kube-apiserver-operator cannot be scraped due to connection refused error

Version-Release number of selected component (if applicable):
4.3.0-0.nightly-2019-12-18-145749-ipv6.1

How reproducible:
Always

Steps to Reproduce:
1. Start a cluster
2. Go to prometheus UI -> targets (this needs to be done with port-forward, due to https://bugzilla.redhat.com/show_bug.cgi?id=1788135, cmd: "-n openshift-monitoring port-forward svc/prometheus-operated 9090")

Actual results:
`openshift-apiserver-operator/openshift-apiserver-operator/0` is DOWN


Expected results:
`openshift-apiserver-operator/openshift-apiserver-operator/0` is UP


Additional info:

--- Additional comment from Pawel Krupa on 2020-01-06 09:34:49 EST ---

It should be `openshift-kube-apiserver-operator/kube-apiserver-operator/0` instead of `openshift-apiserver-operator/openshift-apiserver-operator/0`.

--- Additional comment from Neelesh Agrawal on 2020-01-06 10:56:41 EST ---

Following BZ 1788135 and moving this to 4.4. Will clone for 4.3.z

Comment 4 Ke Wang 2020-05-28 02:44:01 UTC
Encountered difficulties in creating OCP IPV6 4.3 cluster.

Comment 7 errata-xmlrpc 2020-06-03 03:30:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2256


Note You need to log in before you can comment on or make changes to this bug.