Bug 1813964

Summary: [OAS] fixes configmap "extension-apiserver-authentication" not found
Product: OpenShift Container Platform Reporter: Xingxing Xia <xxia>
Component: openshift-apiserverAssignee: Lukasz Szaszkiewicz <lszaszki>
Status: CLOSED ERRATA QA Contact: Xingxing Xia <xxia>
Severity: urgent Docs Contact:
Priority: urgent    
Version: 4.5CC: aos-bugs, lszaszki, mfojtik, shsaxena, xxia
Target Milestone: ---Keywords: Reopened
Target Release: 4.5.0Flags: shsaxena: needinfo?
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: 1812878
: 1814207 1820486 (view as bug list) Environment:
Last Closed: 2020-12-18 15:05:01 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1814207    

Description Xingxing Xia 2020-03-16 15:08:23 UTC
+++ This bug was initially created as a clone of Bug #1812878 +++

4.5.0-0.nightly-2020-03-15-220309 OAS log also has same issue:
$ oc logs deploy/apiserver -n openshift-apiserver
Copying system trust bundle
W0316 02:58:17.187306       1 configmap_cafile_content.go:102] unable to load initial CA bundle for: "client-ca::kube-system::extension-apiserver-authentication::client-ca-file" due to: configmap "extension-apiserver-authentication" not found
W0316 02:58:17.187606       1 configmap_cafile_content.go:102] unable to load initial CA bundle for: "client-ca::kube-system::extension-apiserver-authentication::requestheader-client-ca-file" due to: configmap "extension-apiserver-authentication" not found
...

Comment 3 Xingxing Xia 2020-04-03 06:02:38 UTC
Verified in 4.5.0-0.nightly-2020-04-02-222604, issue is gone.

Comment 5 errata-xmlrpc 2020-07-13 17:20:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409