Bug 1812878 - fixes configmap "extension-apiserver-authentication" not found
Summary: fixes configmap "extension-apiserver-authentication" not found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: kube-apiserver
Version: 4.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Lukasz Szaszkiewicz
QA Contact: Xingxing Xia
URL:
Whiteboard:
: 1820502 (view as bug list)
Depends On:
Blocks: 1812877
TreeView+ depends on / blocked
 
Reported: 2020-03-12 12:20 UTC by Lukasz Szaszkiewicz
Modified: 2020-08-04 18:05 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1812877
: 1813964 1820502 1820509 1820517 (view as bug list)
Environment:
Last Closed: 2020-08-04 18:05:02 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-08-04 18:05:06 UTC

Description Lukasz Szaszkiewicz 2020-03-12 12:20:58 UTC
+++ This bug was initially created as a clone of Bug #1812877 +++

we need to move https://github.com/kubernetes/kubernetes/pull/88763 so that errors like configmap_cafile_content.go:102] unable to load initial CA bundle for: "client-ca::kube-system::extension-apiserver-authentication::client-ca-file" due to: configmap "extension-apiserver-authentication" not found will not be printed at the server startup.

Comment 1 Lukasz Szaszkiewicz 2020-03-13 08:24:47 UTC
The pull I referenced in my previous comment will be part of the upcoming Kubernetes release (1.18). The new release will be incorporated into Origin in this sprint. 

Given that and the fact that the fix only removes a line from the log file, I'm moving this issue to VERIFIED state.

Comment 3 Maciej Szulik 2020-04-03 11:12:45 UTC
*** Bug 1820502 has been marked as a duplicate of this bug. ***

Comment 5 errata-xmlrpc 2020-08-04 18:05:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.