Bug 1814207 - [OAS] fixes configmap "extension-apiserver-authentication" not found
Summary: [OAS] fixes configmap "extension-apiserver-authentication" not found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-apiserver
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Lukasz Szaszkiewicz
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On: 1813964
Blocks: 1824127
TreeView+ depends on / blocked
 
Reported: 2020-03-17 11:29 UTC by Xingxing Xia
Modified: 2020-05-04 11:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1813964
: 1824127 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:46:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift kubernetes-apiserver pull 6 None closed Bug 1814207: fixes configmap "extension-apiserver-authentication" not found 2020-06-29 01:46:10 UTC
Github openshift openshift-apiserver pull 87 None closed Bug 1814207: fixes configmap "extension-apiserver-authentication" not found 2020-06-29 01:46:10 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:46:54 UTC

Description Xingxing Xia 2020-03-17 11:29:47 UTC
+++ This bug was initially created as a clone of Bug #1813964 +++

+++ This bug was initially created as a clone of Bug #1812878 +++

4.4 (e.g. 4.4.0-0.nightly-2020-03-16-124852) also has same issue:
Copying system trust bundle
W0317 02:21:18.434882       1 configmap_cafile_content.go:102] unable to load initial CA bundle for: "client-ca::kube-system::extension-apiserver-authentication::client-ca-file" due to: configmap "extension-apiserver-authentication" not found
W0317 02:21:18.435084       1 configmap_cafile_content.go:102] unable to load initial CA bundle for: "client-ca::kube-system::extension-apiserver-authentication::requestheader-client-ca-file" due to: configmap "extension-apiserver-authentication" not found
I0317 02:21:18.491599       1 audit.go:368] Using audit backend: ignoreErrors<log>
I0317 02:21:18.496580       1 plugins.go:84] Registered admission plugin "NamespaceLifecycle"
...

Not a 4.4 blocker. But is an issue worth to address.

Comment 3 Xingxing Xia 2020-04-03 06:10:19 UTC
https://github.com/openshift/openshift-apiserver/pull/87 not yet merged. Changing status.

Comment 4 Xingxing Xia 2020-04-14 07:13:23 UTC
Verified in 4.4.0-0.nightly-2020-04-13-113747. The issue is gone.

Comment 6 errata-xmlrpc 2020-05-04 11:46:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.