Bug 1817659

Summary: annobin ICE: attempting to access a gcc command line option that is not stored in global_options
Product: [Fedora] Fedora Reporter: Jerry James <loganjerry>
Component: annobinAssignee: Nick Clifton <nickc>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: unspecified    
Version: rawhideCC: amessina, besser82, fweimer, jakub, jcpunk, kloczko.tomasz, mtasaka, nickc, pmatilai, ppisar, rjones, sanjay.ankur
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: annobin-9.21-1.fc33 annobin-9.21-1.fc32 Doc Type: No Doc Update
Doc Text:
If this bug requires documentation, please select an appropriate Doc Type value.
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-05-06 04:29:56 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Jerry James 2020-03-26 18:07:39 UTC
Description of problem:
While building a new version of libpoly (see https://koji.fedoraproject.org/koji/taskinfo?taskID=42779532), I found that the build log is full of these messages:

annobin: /builddir/build/BUILD/libpoly-0.1.8/src/utils/open_memstream.c: ICE: attempting to access a gcc command line option that is not stored in global_options
annobin: /builddir/build/BUILD/libpoly-0.1.8/src/utils/open_memstream.c: ICE: Please contact the annobin maintainer with details of this problem

Version-Release number of selected component (if applicable):
annobin-9.14-1.fc33.i686

How reproducible:
Always

Steps to Reproduce:
1. fedpkg clone libpoly
2. fedpkg srpm libpoly
3. Build the resulting srpm for Rawhide

Actual results:
Lots of annobin complaints as shown above.

Expected results:
No annobin complaints.

Additional info:

Comment 1 Nick Clifton 2020-03-27 08:32:13 UTC
Hi Jerry,

  Darn - I thought that this problem could never happen in real life...
  I am investigating now.

Cheers
  Nick

Comment 2 Nick Clifton 2020-03-27 10:42:56 UTC
Hi Jerry,

  Sorry about that.  The problem should now be fixed.  If you try your build again the error messages should be gone.

Cheers
  Nick

Comment 3 Jerry James 2020-03-27 14:51:19 UTC
Thank you for the quick fix, Nick.

Comment 4 Marek Polacek 2020-03-28 14:00:33 UTC
*** Bug 1818451 has been marked as a duplicate of this bug. ***

Comment 6 Petr Pisar 2020-04-22 07:32:01 UTC
(In reply to Björn 'besser82' Esser from comment #5)
> Looks like the problem is back: 
> https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/
> thread/EXFCXRDO5ZT4VRV6FHAJ72MBY7FJTEGS/

annobin-9.20-1.fc33.x86_64 and gcc-10.0.1-0.12.fc33.x86_64.

Comment 7 Nick Clifton 2020-04-22 12:11:54 UTC
*sigh*  Yes - gcc has changed again and now the -fstack_clash_protection option has moved.
At least that annobin did not stop the compilation from completing.

I have now create annobin-9.21.1-fc33 which should resolve this problem permanently. Mind you I said as much last time and it did not work.  Ho hum.  Anyway please try rebuilding ocaml-mccs and see if the issue has been resolved.

Comment 8 Anthony Messina 2020-05-03 15:23:06 UTC
I see this same issue building in a mock chroot on Fedora 32:

annobin-9.19-1.fc32
gcc-10.0.1-0.13.fc32

Comment 9 Ankur Sinha (FranciscoD) 2020-05-03 18:45:19 UTC
Seeing this on F32 after an update:

annobin: ~/.vim/plugged/YouCompleteMe/third_party/ycmd/third_party/cregex/regex_3/_regex.c: ICE: attempting to access a gcc command line option that is not stored in global_options
annobin: ~/.vim/plugged/YouCompleteMe/third_party/ycmd/third_party/cregex/regex_3/_regex.c: ICE: Please contact the annobin maintainer with details of this problem
annobin: ~/.vim/plugged/YouCompleteMe/third_party/ycmd/third_party/cregex/regex_3/_regex.c: debugging: index = 853 max = 1919


(I was building YouCompleteMe)

annobin-9.19-1.fc32.x86_64
gcc-10.0.1-0.13.fc32.x86_64

Comment 10 Fedora Update System 2020-05-04 09:40:01 UTC
FEDORA-2020-8199708a59 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-8199708a59

Comment 11 Nick Clifton 2020-05-04 09:41:39 UTC
Hi Ankur,

> Seeing this on F32 after an update:

Sorry - my bad.  I forgot to update F32 after updating rawhide.
I have now built annobin-9.21-1.fc32 and submitted a Bodhi update request.

Cheers
  Nick

Comment 12 Ankur Sinha (FranciscoD) 2020-05-04 09:49:32 UTC
Hi Nick,

No worries. Thanks for pushing the update. That fixes it. Karma given.

Cheers,
Ankur

Comment 13 Fedora Update System 2020-05-05 05:11:53 UTC
FEDORA-2020-8199708a59 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-8199708a59`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-8199708a59

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Panu Matilainen 2020-05-05 10:13:26 UTC
Just in case others run into this: if the ICE messages seem to persist after updating to the fixed annobin, try clearing the compiler cache: "ccache -C"

Comment 15 Nick Clifton 2020-05-05 15:32:32 UTC
*** Bug 1831738 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2020-05-06 04:29:56 UTC
FEDORA-2020-8199708a59 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.