Bug 1826409

Summary: Create operand form fails client side validation on blank, non-required fields
Product: OpenShift Container Platform Reporter: bpeterse
Component: Management ConsoleAssignee: Jon Jackson <jonjacks>
Status: CLOSED ERRATA QA Contact: Yadan Pei <yapei>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 4.4CC: aos-bugs, bpeterse, hasha, jokerman, jonjacks, yapei
Target Milestone: ---   
Target Release: 4.4.z   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1826121 Environment:
Last Closed: 2020-06-02 11:17:50 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On: 1826121    
Bug Blocks:    

Description bpeterse 2020-04-21 15:46:18 UTC
+++ This bug was initially created as a clone of Bug #1826121 +++

Description of problem:
Create operand form fails to submit if a blank, non-required field has validation parameters defined and does not meet them.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always

Steps to Reproduce:
1. Install the portworx operator
2. From the Portworx operator details page, create a Storage Cluster instance
3. Click 'Edit Form' in the top right
4. Scroll to the bottom of the form and click 'Submit'

Actual results:
Form fails to submit and a validation error is shown on the 'Start Port' field, with message 'Must be greater than 0' 


Expected results:
Form should submit successfully since the 'Start Port' field is not required and is therefore allowed to be blank.


Additional info:

--- Additional comment from  on 2020-04-21 15:46:03 UTC ---

This feature has changed significantly in 4.5, as a result this bug is irrelevant and only exists so that we can get a fix to 4.4.

Comment 3 shahan 2020-05-26 04:09:57 UTC
The Storage Cluster can be created sucessfully via form
4.4.0-0.nightly-2020-05-25-115719

Comment 5 errata-xmlrpc 2020-06-02 11:17:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2310