Bug 1826409 - Create operand form fails client side validation on blank, non-required fields
Summary: Create operand form fails client side validation on blank, non-required fields
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.z
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1826121
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-04-21 15:46 UTC by bpeterse
Modified: 2020-06-02 11:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1826121
Environment:
Last Closed: 2020-06-02 11:17:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 5124 None closed Bug 1826409: Fix create operand validation 2020-06-18 14:21:30 UTC
Red Hat Product Errata RHBA-2020:2310 None None None 2020-06-02 11:18:29 UTC

Description bpeterse 2020-04-21 15:46:18 UTC
+++ This bug was initially created as a clone of Bug #1826121 +++

Description of problem:
Create operand form fails to submit if a blank, non-required field has validation parameters defined and does not meet them.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always

Steps to Reproduce:
1. Install the portworx operator
2. From the Portworx operator details page, create a Storage Cluster instance
3. Click 'Edit Form' in the top right
4. Scroll to the bottom of the form and click 'Submit'

Actual results:
Form fails to submit and a validation error is shown on the 'Start Port' field, with message 'Must be greater than 0' 


Expected results:
Form should submit successfully since the 'Start Port' field is not required and is therefore allowed to be blank.


Additional info:

--- Additional comment from  on 2020-04-21 15:46:03 UTC ---

This feature has changed significantly in 4.5, as a result this bug is irrelevant and only exists so that we can get a fix to 4.4.

Comment 3 shahan 2020-05-26 04:09:57 UTC
The Storage Cluster can be created sucessfully via form
4.4.0-0.nightly-2020-05-25-115719

Comment 5 errata-xmlrpc 2020-06-02 11:17:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2310


Note You need to log in before you can comment on or make changes to this bug.