Bug 1826121 - Create operand form fails client side validation on blank, non-required fields
Summary: Create operand form fails client side validation on blank, non-required fields
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Jon Jackson
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1826409
TreeView+ depends on / blocked
 
Reported: 2020-04-20 23:53 UTC by Jon Jackson
Modified: 2020-07-13 17:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: On the operand creation form, if a field had validation rules defined, they were always checked on submit, even if the field was not required and blank. Consequence: Non required blank fields could fail validation. Fix: Update validation logic to exclude empty, non-required fields. Result: Empty, non-required fields no longer cause validation failures.
Clone Of:
: 1826409 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:29:33 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:29:48 UTC

Description Jon Jackson 2020-04-20 23:53:26 UTC
Description of problem:
Create operand form fails to submit if a blank, non-required field has validation parameters defined and does not meet them.

Version-Release number of selected component (if applicable):
4.4

How reproducible:
Always

Steps to Reproduce:
1. Install the portworx operator
2. From the Portworx operator details page, create a Storage Cluster instance
3. Click 'Edit Form' in the top right
4. Scroll to the bottom of the form and click 'Submit'

Actual results:
Form fails to submit and a validation error is shown on the 'Start Port' field, with message 'Must be greater than 0' 


Expected results:
Form should submit successfully since the 'Start Port' field is not required and is therefore allowed to be blank.


Additional info:

Comment 1 bpeterse 2020-04-21 15:46:03 UTC
This feature has changed significantly in 4.5, as a result this bug is irrelevant and only exists so that we can get a fix to 4.4.

Comment 2 Yanping Zhang 2020-04-23 06:18:17 UTC
According to Comment 1, no fix is needed for 4.5, so move the bug to Verified.

Comment 4 errata-xmlrpc 2020-07-13 17:29:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.