Bug 1846170

Summary: Downloading libretto cores won't work
Product: [Fedora] Fedora Reporter: Jesús Abelardo Saldívar Aguilar <jasaldivara>
Component: retroarchAssignee: Artem <ego.cordatus>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 32CC: ego.cordatus, mixask8, romulasry
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: retroarch-1.9.9-3.fc33 retroarch-1.9.9-3.fc34 retroarch-1.9.9-3.fc35 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-08-19 14:57:36 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Jesús Abelardo Saldívar Aguilar 2020-06-10 23:53:14 UTC
Description of problem:

I downloaded a new core (Beetle PSX) using the core online updater.

Retroarch shows a message about core succesfully installed.

When I go to the "Load Core" screen, the new core doesn't show up. Even after
closing and opening retroarch, the new core never shows up.



Version-Release number of selected component (if applicable):



1.8.8-1.fc32


How reproducible:


Steps to Reproduce:
1. Download a new core from core updater
2. Try to load the new core
3. (It doesn't show up)

Actual results:

The newly downloaded core doesn't show up.

Expected results:


The newly downloaded core shows up and works correctly.

Additional info:



When I run retroarch from terminal emulator using '--verbose' flag, it displays
an error message when I download the core:

[ERROR] Download of '/usr/lib64/libretro/mednafen_psx_libretro.so.zip' failed: Write failed.

So, retroarch is trying to write the downloaded file to the system folder
/usr/lib64 whitout permissions instead of a local folder like
/.config/retroarch/cores

Comment 1 Artem 2020-06-11 01:30:45 UTC
You need to change dir for cores as well:

Settings -> Directories -> Core

Comment 2 Artem 2021-02-17 00:35:59 UTC
*** Bug 1927351 has been marked as a duplicate of this bug. ***

Comment 3 Artem 2021-10-02 09:26:44 UTC
Since retroarch-1.9.9-3 there is more convenient way to enable network access and downloading more cores. To download and install more libretro cores please read included README.Fedora file:

  $ xdg-open /usr/share/doc/retroarch/README.fedora.md

Comment 4 Fedora Update System 2021-10-02 09:28:32 UTC
FEDORA-2021-3f497c308f has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2021-3f497c308f

Comment 5 Fedora Update System 2021-10-02 09:29:15 UTC
FEDORA-2021-f58db28ef2 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-f58db28ef2

Comment 6 Fedora Update System 2021-10-02 09:29:29 UTC
FEDORA-2021-ac32f0a82e has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2021-ac32f0a82e

Comment 7 Artem 2021-10-03 10:10:39 UTC
*** Bug 1962391 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2021-10-07 17:08:09 UTC
FEDORA-2021-ac32f0a82e has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 9 Fedora Update System 2021-10-07 17:18:16 UTC
FEDORA-2021-f58db28ef2 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 10 Fedora Update System 2021-10-29 22:54:41 UTC
FEDORA-2021-3f497c308f has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.