Bug 1896608

Summary: nothing provides python3.9dist(secretstorage) >= 3.2 needed by python3-keyring-21.5.0-1.fc33.noarch
Product: [Fedora] Fedora Reporter: Matt Fagnani <matt.fagnani>
Component: python-keyringAssignee: Christopher Tubbs <ctubbsii>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 33CC: apevec, bperkins, cickumqt, ctubbsii, igor.raits, redhat-bugzilla, rtnpro
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2020-11-27 05:25:31 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Matt Fagnani 2020-11-11 03:20:27 UTC
Description of problem:

I ran sudo dnf upgrade --refresh in an F33 KDE Plasma spin installation with updates-testing enabled on 2020-11-10. A dnf error indicated that python3-keyring-21.5.0-1.fc33.noarch couldn't be updated because python3.9dist(secretstorage) >= 3.2 was unavailable.

Problem: cannot install the best update candidate for package python3-keyring-21.3.1-1.fc33.noarch
  - nothing provides python3.9dist(secretstorage) >= 3.2 needed by python3-keyring-21.5.0-1.fc33.noarch
 Package                   Architecture     Version                   Repository                 Size
Skipping packages with broken dependencies:
 python3-keyring           noarch           21.5.0-1.fc33             updates-testing            76 k

Transaction Summary
Skip  1 Package

Version-Release number of selected component (if applicable):

How reproducible:
2 of 2 times

Steps to Reproduce:
1. Boot an F33 KDE Plasma spin installation with updates-testing enabled
2. Log in to Plasma on Wayland
3. start konsole
4. sudo dnf upgrade --refresh

Actual results:
nothing provides python3.9dist(secretstorage) >= 3.2 needed by python3-keyring-21.5.0-1.fc33.noarch

Expected results:
no dnf error

Additional info:
python-SecretStorage-3.1.2-2.fc33 provides python3.9dist(secretstorage) = 3.1.2 and is the latest version in koji.

secretstorage 3.2.0 was released 2020-11-7 https://github.com/mitya57/secretstorage/tags and might need to be updated in F33 and added to the python-keyring-21.5.0-1.fc33 update at https://bodhi.fedoraproject.org/updates/FEDORA-2020-06256bf669

Comment 1 Christopher Tubbs 2020-11-11 04:35:14 UTC
Fixing this might be possible in F33 by updating secretstorage to 3.2.0, but I'd like the same SPEC to build for epel8, F32, F33, and rawhide. It seems the secretstorage requirement is too aggressive, and seems to be generated by the automatic python dependencies stuff. This version does not *actually* require a version that new... nothing has changed to require the newer version.

I'm not sure if it would be better to patch the upstream to be less aggressive in its requirements, or to wait for all of the supported releasevers to update to the newer version of secretstorage.

Comment 2 Christopher Tubbs 2020-11-11 04:42:46 UTC
Oh no! I'm wrong... it *does* require 3.2 or later. It uses `secretstorage.check_service_availability`, which is new in 3.2.
So, that will have to be added first, for all supported releasevers (epel8, F32, F33, rawhide), or else I'll have to revert this change across all those branches.

Comment 3 Christopher Tubbs 2020-11-27 05:25:31 UTC
This was worked through and fixed in the update for bug 1873845; closing as a duplicate of that one

*** This bug has been marked as a duplicate of bug 1873845 ***