Bug 1896608 - nothing provides python3.9dist(secretstorage) >= 3.2 needed by python3-keyring-21.5.0-1.fc33.noarch
Summary: nothing provides python3.9dist(secretstorage) >= 3.2 needed by python3-keyrin...
Keywords:
Status: CLOSED DUPLICATE of bug 1873845
Alias: None
Product: Fedora
Classification: Fedora
Component: python-keyring
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christopher Tubbs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-11-11 03:20 UTC by Matt Fagnani
Modified: 2020-11-27 05:26 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-27 05:25:31 UTC
Type: Bug


Attachments (Terms of Use)

Description Matt Fagnani 2020-11-11 03:20:27 UTC
Description of problem:

I ran sudo dnf upgrade --refresh in an F33 KDE Plasma spin installation with updates-testing enabled on 2020-11-10. A dnf error indicated that python3-keyring-21.5.0-1.fc33.noarch couldn't be updated because python3.9dist(secretstorage) >= 3.2 was unavailable.

Problem: cannot install the best update candidate for package python3-keyring-21.3.1-1.fc33.noarch
  - nothing provides python3.9dist(secretstorage) >= 3.2 needed by python3-keyring-21.5.0-1.fc33.noarch
======================================================================================================
 Package                   Architecture     Version                   Repository                 Size
======================================================================================================
Skipping packages with broken dependencies:
 python3-keyring           noarch           21.5.0-1.fc33             updates-testing            76 k

Transaction Summary
======================================================================================================
Skip  1 Package


Version-Release number of selected component (if applicable):
python3-keyring-21.5.0-1.fc33.noarch

How reproducible:
2 of 2 times

Steps to Reproduce:
1. Boot an F33 KDE Plasma spin installation with updates-testing enabled
2. Log in to Plasma on Wayland
3. start konsole
4. sudo dnf upgrade --refresh

Actual results:
nothing provides python3.9dist(secretstorage) >= 3.2 needed by python3-keyring-21.5.0-1.fc33.noarch

Expected results:
no dnf error

Additional info:
python-SecretStorage-3.1.2-2.fc33 provides python3.9dist(secretstorage) = 3.1.2 and is the latest version in koji.
https://koji.fedoraproject.org/koji/buildinfo?buildID=1565041

secretstorage 3.2.0 was released 2020-11-7 https://github.com/mitya57/secretstorage/tags and might need to be updated in F33 and added to the python-keyring-21.5.0-1.fc33 update at https://bodhi.fedoraproject.org/updates/FEDORA-2020-06256bf669

Comment 1 Christopher Tubbs 2020-11-11 04:35:14 UTC
Fixing this might be possible in F33 by updating secretstorage to 3.2.0, but I'd like the same SPEC to build for epel8, F32, F33, and rawhide. It seems the secretstorage requirement is too aggressive, and seems to be generated by the automatic python dependencies stuff. This version does not *actually* require a version that new... nothing has changed to require the newer version.

I'm not sure if it would be better to patch the upstream to be less aggressive in its requirements, or to wait for all of the supported releasevers to update to the newer version of secretstorage.

Comment 2 Christopher Tubbs 2020-11-11 04:42:46 UTC
Oh no! I'm wrong... it *does* require 3.2 or later. It uses `secretstorage.check_service_availability`, which is new in 3.2.
So, that will have to be added first, for all supported releasevers (epel8, F32, F33, rawhide), or else I'll have to revert this change across all those branches.

Comment 3 Christopher Tubbs 2020-11-27 05:25:31 UTC
This was worked through and fixed in the update for bug 1873845; closing as a duplicate of that one

*** This bug has been marked as a duplicate of bug 1873845 ***


Note You need to log in before you can comment on or make changes to this bug.