Bug 1873845 - python-keyring-21.5.0 is available
Summary: python-keyring-21.5.0 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-keyring
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christopher Tubbs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1896608 (view as bug list)
Depends On: 1869811 1895611
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-08-30 15:07 UTC by Upstream Release Monitoring
Modified: 2020-11-28 02:10 UTC (History)
9 users (show)

Fixed In Version: python-keyring-21.5.0-1.fc33 python-keyring-21.5.0-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-11-27 01:21:01 UTC
Type: ---


Attachments (Terms of Use)
[patch] Update to 21.4.0 (#1873845) (1009 bytes, patch)
2020-08-30 15:07 UTC, Upstream Release Monitoring
no flags Details | Diff
[patch] Update to 21.5.0 (#1873845) (1008 bytes, patch)
2020-11-07 18:22 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2020-08-30 15:07:16 UTC
Latest upstream release: 21.4.0
Current version/release in rawhide: 21.2.0-2.fc33
URL: https://github.com/jaraco/keyring

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/3901/

Comment 1 Upstream Release Monitoring 2020-08-30 15:07:20 UTC
Created attachment 1713076 [details]
[patch] Update to 21.4.0 (#1873845)

Comment 2 Upstream Release Monitoring 2020-11-07 18:22:40 UTC
Latest upstream release: 21.5.0
Current version/release in rawhide: 21.3.1-1.fc34
URL: https://github.com/jaraco/keyring

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from anitya: https://release-monitoring.org/project/3901/

Comment 3 Upstream Release Monitoring 2020-11-07 18:22:45 UTC
Created attachment 1727422 [details]
[patch] Update to 21.5.0 (#1873845)

Comment 4 Upstream Release Monitoring 2020-11-07 18:24:05 UTC
the-new-hotness/release-monitoring.org's scratch build of python-keyring-21.5.0-1.fc32.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=55123494

Comment 5 Joel Capitao 2020-11-09 15:23:17 UTC
PR proposed: https://src.fedoraproject.org/rpms/python-keyring/pull-request/7

Comment 6 Fedora Update System 2020-11-10 20:47:06 UTC
FEDORA-2020-06256bf669 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-06256bf669

Comment 7 Fedora Update System 2020-11-11 02:18:54 UTC
FEDORA-2020-24198e0457 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-24198e0457`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-24198e0457

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2020-11-11 02:20:25 UTC
FEDORA-2020-06256bf669 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-06256bf669`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-06256bf669

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Fedora Update System 2020-11-11 02:52:48 UTC
FEDORA-EPEL-2020-dfe69c0284 has been pushed to the Fedora EPEL 8 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2020-dfe69c0284

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Brian Morrison 2020-11-11 16:31:05 UTC
Attempted to update package results in this:


Dependencies resolved.

 Problem: cannot install the best update candidate for package python3-keyring-21.3.1-1.fc33.noarch
  - nothing provides python3.9dist(secretstorage) >= 3.2 needed by python3-keyring-21.5.0-1.fc33.noarch

There is no update for python-secretstorage available.

Comment 11 Fedora Update System 2020-11-11 18:58:18 UTC
FEDORA-2020-24198e0457 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-24198e0457

Comment 12 Fedora Update System 2020-11-11 18:58:39 UTC
FEDORA-2020-06256bf669 has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-06256bf669

Comment 13 Adam Williamson 2020-11-11 18:59:52 UTC
I built the newer secretstorage for F32, F33 and Rawhide, and edited the F32 and F33 updates.

Comment 14 Brian Morrison 2020-11-11 19:06:25 UTC
Thanks Adam, that has sorted it out!

Comment 15 Fedora Update System 2020-11-12 04:24:25 UTC
FEDORA-2020-06256bf669 has been pushed to the Fedora 33 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-06256bf669`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-06256bf669

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2020-11-12 04:42:18 UTC
FEDORA-2020-24198e0457 has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-24198e0457`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-24198e0457

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2020-11-27 01:21:01 UTC
FEDORA-2020-06256bf669 has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 18 Christopher Tubbs 2020-11-27 05:25:06 UTC
*** Bug 1896608 has been marked as a duplicate of this bug. ***

Comment 19 Fedora Update System 2020-11-28 02:10:07 UTC
FEDORA-2020-24198e0457 has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.