Bug 192548
| Summary: | Local printer on lpt1 won't work after CUPS update | ||||||||
|---|---|---|---|---|---|---|---|---|---|
| Product: | [Fedora] Fedora | Reporter: | Lieven <lieven.vanhulle> | ||||||
| Component: | cups | Assignee: | Tim Waugh <twaugh> | ||||||
| Status: | CLOSED ERRATA | QA Contact: | |||||||
| Severity: | medium | Docs Contact: | |||||||
| Priority: | medium | ||||||||
| Version: | 5 | CC: | fcdocs | ||||||
| Target Milestone: | --- | ||||||||
| Target Release: | --- | ||||||||
| Hardware: | i586 | ||||||||
| OS: | Linux | ||||||||
| Whiteboard: | |||||||||
| Fixed In Version: | 1.2.1-1.2 | Doc Type: | Bug Fix | ||||||
| Doc Text: | Story Points: | --- | |||||||
| Clone Of: | Environment: | ||||||||
| Last Closed: | 2006-05-23 22:08:09 UTC | Type: | --- | ||||||
| Regression: | --- | Mount Type: | --- | ||||||
| Documentation: | --- | CRM: | |||||||
| Verified Versions: | Category: | --- | |||||||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | |||||||
| Cloudforms Team: | --- | Target Upstream Version: | |||||||
| Embargoed: | |||||||||
| Bug Depends On: | 192585 | ||||||||
| Bug Blocks: | 150223 | ||||||||
| Attachments: |
|
||||||||
|
Description
Lieven
2006-05-20 12:32:40 UTC
Thanks for the report. I'll need a bit more information: 1. What does 'rpm -q cups' say? 2. At the point where you have just sent a print job and the queue becomes disabled, what does 'lpstat -t' say? 3. It would also be useful to see the /var/log/cups/error_log file. Thanks. 'rpm -q cups' says : cups-1.2.0-1.1
before the print job 'lpstat -t' says:
scheduler is running
system default destination: hp950c
device for hp950c: parallel:/dev/lp0
device for laser: socket://192.168.1.152:35
hp950c accepting requests since za 20 mei 2006 20:35:21 CEST
laser accepting requests since do 18 mei 2006 19:48:54 CEST
printer hp950c is idle. enabled since za 20 mei 2006 20:35:21 CEST
printer laser is idle. enabled since do 18 mei 2006 19:48:54 CEST
After sending the print job 'lpstat -t' says:
scheduler is running
system default destination: hp950c
device for hp950c: parallel:/dev/lp0
device for laser: socket://192.168.1.152:35
hp950c accepting requests since za 20 mei 2006 20:37:47 CEST
laser accepting requests since do 18 mei 2006 19:48:54 CEST
printer hp950c disabled since za 20 mei 2006 20:37:47 CEST -
Unable to open parallel port device file "/dev/lp0": Permission denied
printer laser is idle. enabled since do 18 mei 2006 19:48:54 CEST
hp950c-172 root 15360 za 20 mei 2006 20:37:40 CEST
extract of the error_log:
E [20/May/2006:20:37:22 +0200] CUPS-Get-Default client-error-not-found: No
default printer
E [20/May/2006:20:37:27 +0200] CUPS-Get-Default client-error-not-found: No
default printer
E [20/May/2006:20:37:32 +0200] CUPS-Get-Default client-error-not-found: No
default printer
I [20/May/2006:20:37:40 +0200] Adding start banner page "none" to job 172.
I [20/May/2006:20:37:40 +0200] Job 172 queued on "hp950c" by "root".
I [20/May/2006:20:37:40 +0200] Started filter /usr/lib/cups/filter/pstops (PID
11507) for job 172.
I [20/May/2006:20:37:40 +0200] Started filter /usr/lib/cups/filter/foomatic-rip
(PID 11508) for job 172.
I [20/May/2006:20:37:40 +0200] Started backend /usr/lib/cups/backend/parallel
(PID 11509) for job 172.
E [20/May/2006:20:37:40 +0200] PID 11509 (/usr/lib/cups/backend/parallel)
stopped with status 1!
I [20/May/2006:20:37:40 +0200] Hint: Try setting the LogLevel to "debug" to find
out more.
E [20/May/2006:20:37:40 +0200] [Job 172] Unable to open parallel port device
file "/dev/lp0": Permission denied
E [20/May/2006:20:37:44 +0200] CUPS-Get-Default client-error-not-found: No
default printer
E [20/May/2006:20:37:47 +0200] PID 11508 (/usr/lib/cups/filter/foomatic-rip)
stopped with status 9!
I [20/May/2006:20:37:47 +0200] Hint: Try setting the LogLevel to "debug" to find
out more.
I [20/May/2006:20:37:47 +0200] [Job 172] Backend returned status 1 (failed)
I [20/May/2006:20:37:47 +0200] Saving printers.conf...
E [20/May/2006:20:37:49 +0200] CUPS-Get-Default client-error-not-found: No
default printer
E [20/May/2006:20:37:54 +0200] CUPS-Get-Default client-error-not-found: No
default printer
E [20/May/2006:20:37:59 +0200] CUPS-Get-Default client-error-not-found: No
default printer
E [20/May/2006:20:38:00 +0200] CUPS-Get-Default client-error-not-found: No
default printer
E [20/May/2006:20:38:04 +0200] CUPS-Get-Default client-error-not-found: No
default printer
regards,
Lieven
Okay. Now what does this say? ls -l /dev/lp0 /usr/lib/cups/backend/parallel ls -l /dev/lp0 /usr/lib/cups/backend/parallel gives: crw-rw---- 1 root lp 6, 0 mei 19 07:27 /dev/lp0 -rwxr-xr-x 1 root root 15424 mei 9 00:06 /usr/lib/cups/backend/parallel Hmm, that looks correct. Could you attach /etc/cups/cupsd.conf please? Created attachment 129775 [details]
cupsd configuration file
Ah, KDEPrint has added 'Group sys' which is incorrect, and not what the default as-shipped configuration file has. Since the parallel backend no longer runs as root, this prevents the backend having access to /dev/lp0 -- it needs 'lp' group membership. Until KDEPrint stops writing that sort of configuration file I guess we'll need to switch the parallel backend back to running as root. I thought it had to be something like that because of the 'Permission denied' message. So the problems possibly started after an update of the KDE system. I did not try the lpt0 configuration with Gnome. Thanks for your help and best regards, Lieven As a work-around, you can do this (as root): chmod 0700 /usr/lib/cups/backend/parallel This should no longer be necessary with cups-1.2.1-1.1. Please try 1.2.1-1.2 from here: http://people.redhat.com/twaugh/tmp/cups-fc5/ Does it work correctly for you now? Ok, I have installed the cups-1.2.1-1.2 and it now works fine with LPT0. Thanks again Lieven Created attachment 129888 [details]
cups conf file
Tim:- as requested. Hope it helps!
David: great, thanks. Yes, this has the same root cause and should be fixed in 1.2.1-1.2. Tim, I just received the update. KDE Menu-Settings-PrintingManager test print now works with USB connection. Thanks. Time for bed. I'll probably do some more with it tomorrow. |