Bug 192548 - Local printer on lpt1 won't work after CUPS update
Local printer on lpt1 won't work after CUPS update
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
5
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On: 192585
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-05-20 08:32 EDT by Lieven
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2.1-1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-23 18:08:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cupsd configuration file (18.58 KB, text/plain)
2006-05-20 18:56 EDT, Lieven
no flags Details
cups conf file (18.95 KB, application/octet-stream)
2006-05-23 16:13 EDT, David Fletcher
no flags Details

  None (edit)
Description Lieven 2006-05-20 08:32:40 EDT
Description of problem:
Printer problem since last update.
I have a laser QMS colorprinter on the network and a local hp950c on the 
parallel port.

The laser was still working fine after the CUPS update but the hp950 reported 
'printing is disabled" with lpc status.
Sending a printertask to the printer works but the status gets disabled.

I have removed the hp950 and re-installed it on the interface others: 
hp:/par/DESKJET_950C?device=/dev/parport0

NOT on Parallel LPT #1 ! That didn't work.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.delete the parallel port printer
2.add the printer again but choose lpt#1 as local port instead of the
option:hp:/par/DESKJET_950C?device=/dev/parport0
3.try to print a test page, it will come in the cueue and the printer gets
disabled. Starting the printer will put the printertask again in the queue.
  
Actual results: 


Expected results:


Additional info:the only way to use the parallel port is to use the
option:'hp:/par/DESKJET_950C?device=/dev/parport0' when re-installing the
printer after the CUPS update.

regards,
Lieven
Comment 1 Tim Waugh 2006-05-20 12:40:32 EDT
Thanks for the report.  I'll need a bit more information:

1. What does 'rpm -q cups' say?

2. At the point where you have just sent a print job and the queue becomes
disabled, what does 'lpstat -t' say?

3. It would also be useful to see the /var/log/cups/error_log file.  Thanks.
Comment 2 Lieven 2006-05-20 14:42:02 EDT
'rpm -q cups' says : cups-1.2.0-1.1

before the print job 'lpstat -t' says:
scheduler is running
system default destination: hp950c
device for hp950c: parallel:/dev/lp0
device for laser: socket://192.168.1.152:35
hp950c accepting requests since za 20 mei 2006 20:35:21 CEST
laser accepting requests since do 18 mei 2006 19:48:54 CEST
printer hp950c is idle.  enabled since za 20 mei 2006 20:35:21 CEST
printer laser is idle.  enabled since do 18 mei 2006 19:48:54 CEST


After sending the print job 'lpstat -t' says:
scheduler is running
system default destination: hp950c
device for hp950c: parallel:/dev/lp0
device for laser: socket://192.168.1.152:35
hp950c accepting requests since za 20 mei 2006 20:37:47 CEST
laser accepting requests since do 18 mei 2006 19:48:54 CEST
printer hp950c disabled since za 20 mei 2006 20:37:47 CEST -
        Unable to open parallel port device file "/dev/lp0": Permission denied
printer laser is idle.  enabled since do 18 mei 2006 19:48:54 CEST
hp950c-172              root             15360   za 20 mei 2006 20:37:40 CEST


extract of the error_log:
E [20/May/2006:20:37:22 +0200] CUPS-Get-Default client-error-not-found: No
default printer
E [20/May/2006:20:37:27 +0200] CUPS-Get-Default client-error-not-found: No
default printer
E [20/May/2006:20:37:32 +0200] CUPS-Get-Default client-error-not-found: No
default printer
I [20/May/2006:20:37:40 +0200] Adding start banner page "none" to job 172.
I [20/May/2006:20:37:40 +0200] Job 172 queued on "hp950c" by "root".
I [20/May/2006:20:37:40 +0200] Started filter /usr/lib/cups/filter/pstops (PID
11507) for job 172.
I [20/May/2006:20:37:40 +0200] Started filter /usr/lib/cups/filter/foomatic-rip
(PID 11508) for job 172.
I [20/May/2006:20:37:40 +0200] Started backend /usr/lib/cups/backend/parallel
(PID 11509) for job 172.
E [20/May/2006:20:37:40 +0200] PID 11509 (/usr/lib/cups/backend/parallel)
stopped with status 1!
I [20/May/2006:20:37:40 +0200] Hint: Try setting the LogLevel to "debug" to find
out more.
E [20/May/2006:20:37:40 +0200] [Job 172] Unable to open parallel port device
file "/dev/lp0": Permission denied
E [20/May/2006:20:37:44 +0200] CUPS-Get-Default client-error-not-found: No
default printer
E [20/May/2006:20:37:47 +0200] PID 11508 (/usr/lib/cups/filter/foomatic-rip)
stopped with status 9!
I [20/May/2006:20:37:47 +0200] Hint: Try setting the LogLevel to "debug" to find
out more.
I [20/May/2006:20:37:47 +0200] [Job 172] Backend returned status 1 (failed)
I [20/May/2006:20:37:47 +0200] Saving printers.conf...
E [20/May/2006:20:37:49 +0200] CUPS-Get-Default client-error-not-found: No
default printer
E [20/May/2006:20:37:54 +0200] CUPS-Get-Default client-error-not-found: No
default printer
E [20/May/2006:20:37:59 +0200] CUPS-Get-Default client-error-not-found: No
default printer
E [20/May/2006:20:38:00 +0200] CUPS-Get-Default client-error-not-found: No
default printer
E [20/May/2006:20:38:04 +0200] CUPS-Get-Default client-error-not-found: No
default printer

regards,
Lieven
Comment 3 Tim Waugh 2006-05-20 18:09:32 EDT
Okay.  Now what does this say?

ls -l /dev/lp0 /usr/lib/cups/backend/parallel
Comment 4 Lieven 2006-05-20 18:25:07 EDT
ls -l /dev/lp0 /usr/lib/cups/backend/parallel gives:
crw-rw---- 1 root lp    6, 0 mei 19 07:27 /dev/lp0
-rwxr-xr-x 1 root root 15424 mei  9 00:06 /usr/lib/cups/backend/parallel
Comment 5 Tim Waugh 2006-05-20 18:35:35 EDT
Hmm, that looks correct.  Could you attach /etc/cups/cupsd.conf please?
Comment 6 Lieven 2006-05-20 18:56:00 EDT
Created attachment 129775 [details]
cupsd configuration file
Comment 7 Tim Waugh 2006-05-21 05:00:30 EDT
Ah, KDEPrint has added 'Group sys' which is incorrect, and not what the default
as-shipped configuration file has.  Since the parallel backend no longer runs as
root, this prevents the backend having access to /dev/lp0 -- it needs 'lp' group
membership.

Until KDEPrint stops writing that sort of configuration file I guess we'll need
to switch the parallel backend back to running as root.
Comment 8 Lieven 2006-05-21 05:21:50 EDT
I thought it had to be something like that because of the 'Permission denied'
message. So the problems possibly started after an update of the KDE system.
I did not try the lpt0 configuration with Gnome.


Thanks for your help and best regards,
Lieven
Comment 9 Tim Waugh 2006-05-22 09:52:27 EDT
As a work-around, you can do this (as root):

  chmod 0700 /usr/lib/cups/backend/parallel
Comment 10 Tim Waugh 2006-05-23 04:24:18 EDT
This should no longer be necessary with cups-1.2.1-1.1.
Comment 11 Tim Waugh 2006-05-23 05:33:21 EDT
Please try 1.2.1-1.2 from here:

  http://people.redhat.com/twaugh/tmp/cups-fc5/

Does it work correctly for you now?
Comment 12 Lieven 2006-05-23 07:04:04 EDT
Ok, I have installed the cups-1.2.1-1.2 and it now works fine with LPT0.

Thanks again

Lieven
Comment 13 David Fletcher 2006-05-23 16:13:29 EDT
Created attachment 129888 [details]
cups conf file

Tim:- as requested. Hope it helps!
Comment 14 Tim Waugh 2006-05-23 18:08:09 EDT
David: great, thanks.  Yes, this has the same root cause and should be fixed in
1.2.1-1.2.
Comment 15 David Fletcher 2006-05-23 18:17:17 EDT
Tim,

I just received the update.

KDE Menu-Settings-PrintingManager test print now works with USB connection.

Thanks.

Time for bed.

I'll probably do some more with it tomorrow.

Note You need to log in before you can comment on or make changes to this bug.