Bug 1955674

Summary: Update to support qemu-kvm only in RHEL9
Product: Red Hat Enterprise Linux 9 Reporter: Brian Lane <bcl>
Component: loraxAssignee: Brian Lane <bcl>
Status: MODIFIED --- QA Contact: Release Test Team <release-test-team>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 9.0CC: atodorov, pzatko
Target Milestone: betaKeywords: Triaged
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: lorax-34.9.1-2.el9 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 1898842    

Description Brian Lane 2021-04-30 16:08:27 UTC
Description of problem:
RHEL9, like RHEL8, only has qemu-kvm and provides it as /usr/libexec/qemu-kvm instead of the /usr/bin/qemu-system-* binaries

lorax needs to be adjusted for this change since the codebase in RHEL9 is from Fedora 34.

Comment 1 Brian Lane 2021-04-30 23:57:55 UTC
https://github.com/weldr/lorax/pull/1142

Also filed bug 1955836 for dracut-live problems with ntfs

Comment 2 Brian Lane 2021-05-04 17:05:05 UTC
*** Bug 1956761 has been marked as a duplicate of this bug. ***

Comment 3 Brian Lane 2021-05-05 17:23:53 UTC
*** Bug 1955826 has been marked as a duplicate of this bug. ***