Bug 2009345

Summary: Overview page does not load from openshift console for some set of users after upgrading to 4.7.19
Product: OpenShift Container Platform Reporter: siva kanakala <skanakal>
Component: Dev ConsoleAssignee: Christoph Jerolimov <cjerolim>
Status: CLOSED ERRATA QA Contact: spathak <spathak>
Severity: high Docs Contact:
Priority: high    
Version: 4.7CC: aos-bugs, jhadvig, kdoberst, mfojtik, nmukherj, scuppett, spadgett, surbania, viraj
Target Milestone: ---Keywords: Reopened
Target Release: 4.11.0Flags: skanakal: needinfo-
zherman: needinfo-
Hardware: x86_64   
OS: Linux   
Fixed In Version: Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-08-10 10:37:47 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 2060448    

Description siva kanakala 2021-09-30 12:32:49 UTC
Description of problem:

For some sets of users not able to load the Overview page and it displays a white screen after entering their credentials. 

Version-Release number of selected component (if applicable):

- This issue is only for some sets of users.
- They tried in an incognito window, and a different browser, even tried remotely where other users are able to connect with their account.
- The account is having the same set of roles as other users.
- But when they try by going to a different URL(appending like this https://console-openshift-console.apps.sharedocp4upi46.lab.rdu2.cee.redhat.com/k8s/cluster/projects) for the cluster and then coming back to the Overview page it works. 
- They deleted the account and the identity and after they logged in again it started working without any issue.

How reproducible:

Steps to Reproduce:

Actual results:
The overview page displays a white screen. 

Expected results:
The overview page from the console should be loaded as soon as entering credentials. 

Additional info:

Comment 6 Jakub Hadvig 2021-10-13 22:22:50 UTC
After a investigating the must-gather logs I can see that the oauth-apiserver pods is flooded with following errors:

2021-10-07T11:10:29.929045938Z I1007 11:10:29.929024       1 passthrough.go:48] ccResolverWrapper: sending update to cc: {[{  <nil> 0 <nil>}] <nil> <nil>}
2021-10-07T11:10:29.929045938Z I1007 11:10:29.929039       1 clientconn.go:948] ClientConn switching balancer to "pick_first"
2021-10-07T11:10:29.929165378Z I1007 11:10:29.929138       1 balancer_conn_wrappers.go:78] pickfirstBalancer: HandleSubConnStateChange: 0xc001a17b40, {CONNECTING <nil>}
2021-10-07T11:10:29.937671647Z I1007 11:10:29.937625       1 balancer_conn_wrappers.go:78] pickfirstBalancer: HandleSubConnStateChange: 0xc001a17b40, {READY <nil>}
2021-10-07T11:10:29.938418691Z I1007 11:10:29.938380       1 controlbuf.go:508] transport: loopyWriter.run returning. connection error: desc = "transport is closing"
2021-10-07T11:10:58.013271707Z I1007 11:10:58.013206       1 client.go:360] parsed scheme: "passthrough"

re-assigning to the oauth-apiserver team for further investigation

Comment 7 Sergiusz Urbaniak 2021-10-27 12:22:08 UTC
The log output from https://bugzilla.redhat.com/show_bug.cgi?id=2009345#c6 is expected, this is not a bug.

Comment 8 Samuel Padgett 2021-12-01 15:34:12 UTC
Reopening and assigning back to the console component. Even if those log messages are expected, there is some problem here. The console shouldn't whitescreen.

Comment 9 Kim Dobestein 2021-12-01 16:35:04 UTC
Moving from "high" to "medium" severity because the login piece is working as expected and there is a workaround.  The issue left to resolve this bug is preventing a white screen from showing when this situation occurs.

Comment 24 Christoph Jerolimov 2022-03-03 14:29:26 UTC
Hi, we will bring an update to this soon. Just want to let you know that the issue with namespaces that are just numbers looks different in different versions:

4.6: Just works fine
4.7: Crash
4.8: Does not crash, but the namespace was not automatically selected when switching to it.
4.9 and 4.10: Works fine, but update it to fix potential other issues when a namespace is a number.

Comment 27 Christoph Jerolimov 2022-03-17 10:24:18 UTC
As mentioned here https://bugzilla.redhat.com/show_bug.cgi?id=2009345#c24, this bug only exists on 4.7 and 4.8.

I verified this change on a cluster (4.11.0-0.nightly-2022-03-16-103946) and tested to create, reload and deploy an app in a namespace with just numbers. Works fine.

Mark this issue as verified to backport this change now to 4.10, and then back to 4.9, 4.8 and 4.7.

Comment 28 Christoph Jerolimov 2022-04-11 10:50:07 UTC
@skanakal this is finally backported to 4.7 and part of 4.7.0-0.nightly-2022-04-07-124734.

It will be included in the next 4.7 z-stream release. Can you update your customer with this info to check if his issue is solved with the next release.

Comment 31 errata-xmlrpc 2022-08-10 10:37:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Important: OpenShift Container Platform 4.11.0 bug fix and security update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.


Comment 32 Red Hat Bugzilla 2023-09-15 01:36:22 UTC
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 365 days