Bug 2053637

Summary: Unable to install nodejs due to /usr/bin/pwsh dependency
Product: [Fedora] Fedora Reporter: Ian McInerney <ian.s.mcinerney>
Component: nodejsAssignee: NodeJS Packaging SIG <nodejs-sig>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: high Docs Contact:
Priority: unspecified    
Version: 34CC: chkr, kappa, mrunge, nodejs-sig, sgallagh, thrcka, zsvetlik
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: nodejs-14.19.0-3.fc34 Doc Type: ---
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-02-17 03:06:33 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description Ian McInerney 2022-02-11 16:42:06 UTC
Description of problem:

When running a DNF update on my Fedora 34 system, it prints package resolution errors for nodejs packages because the main nodejs package has developed a dependency on /usr/bin/pwsh, which is not satisfiable in the Fedora repo.

Error message printed:

 Problem 1: cannot install the best update candidate for package nodejs-1:14.18.3-1.fc34.x86_64
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.fc34.x86_64



Version-Release number of selected component (if applicable):

nodejs-1:14.18.3-1.fc34.x86_64



Note:

It looks like the nodejs spec for Fedora 35 removes the executable bit from several Powershell scripts in the corepack package, but the Fedora 34 spec does not (F35 removal: https://src.fedoraproject.org/rpms/nodejs/blob/f35/f/nodejs.spec#_593). The flag removal probably needs to happen in the Fedora 34 specfile as well.



(side note: maybe adding basic gating tests on installability for nodejs would be a good way to catch this? Since if this is uninstallable, it breaks the rest of the ecosystem).

Comment 1 Fedora Update System 2022-02-14 14:11:41 UTC
FEDORA-2022-34905def21 has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-34905def21

Comment 2 Stephen Gallagher 2022-02-14 21:07:13 UTC
*** Bug 2054010 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2022-02-15 02:52:18 UTC
FEDORA-2022-34905def21 has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-34905def21`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-34905def21

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Stephen Gallagher 2022-02-16 13:35:45 UTC
*** Bug 2055081 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2022-02-17 03:06:33 UTC
FEDORA-2022-34905def21 has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.