Bug 2054010 - FTI in Fedora 34: nodejs (nothing provides /usr/bin/pwsh)
Summary: FTI in Fedora 34: nodejs (nothing provides /usr/bin/pwsh)
Keywords:
Status: CLOSED DUPLICATE of bug 2053637
Alias: None
Product: Fedora
Classification: Fedora
Component: nodejs
Version: 34
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: NodeJS Packaging SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-02-13 23:14 UTC by Alex Kapranoff
Modified: 2022-02-14 21:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-02-14 21:07:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Alex Kapranoff 2022-02-13 23:14:57 UTC
Description of problem:

Update from nodejs-1:14.18.3-1.fc34.x86_64 to nodejs-1:14.19.0-2.fc34.x86_64 does not work.

Version-Release number of selected component (if applicable):

nodejs-1:14.18.3-1.fc34.x86_64
nodejs-1:14.19.0-2.fc34.x86_64


How reproducible:

Always

Steps to Reproduce:
1. sudo dnf upgrade --refresh

Actual results:
 Problem 1: cannot install the best update candidate for package nodejs-1:14.18.3-1.fc34.x86_64
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.fc34.x86_64
 Problem 2: package nodejs-full-i18n-1:14.19.0-2.fc34.x86_64 requires nodejs(x86-64) = 1:14.19.0-2.fc34, but none of the providers can be installed
  - cannot install the best update candidate for package nodejs-full-i18n-1:14.18.3-1.fc34.x86_64
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.fc34.x86_64
 Problem 3: package npm-1:6.14.16-1.14.19.0.2.fc34.x86_64 requires nodejs = 1:14.19.0-2.fc34, but none of the providers can be installed
  - cannot install the best update candidate for package npm-1:6.14.15-1.14.18.3.1.fc34.x86_64
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.fc34.i686
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.fc34.x86_64
 Problem 4: package yarn-1.22.17-1.noarch requires nodejs, but none of the providers can be installed
  - package nodejs-docs-1:14.19.0-2.fc34.noarch conflicts with nodejs < 1:14.19.0-2.fc34 provided by nodejs-1:14.18.3-1.fc34.x86_64
  - package nodejs-docs-1:14.19.0-2.fc34.noarch conflicts with nodejs < 1:14.19.0-2.fc34 provided by nodejs-1:14.16.0-4.fc34.i686
  - package nodejs-docs-1:14.19.0-2.fc34.noarch conflicts with nodejs < 1:14.19.0-2.fc34 provided by nodejs-1:14.16.0-4.fc34.x86_64
  - package nodejs-docs-1:14.19.0-2.fc34.noarch conflicts with nodejs < 1:14.19.0-2.fc34 provided by nodejs-1:14.16.1-1.fc34.x86_64
  - package nodejs-docs-1:14.19.0-2.fc34.noarch conflicts with nodejs < 1:14.19.0-2.fc34 provided by nodejs-1:14.17.0-1.fc34.x86_64
  - package nodejs-docs-1:14.19.0-2.fc34.noarch conflicts with nodejs < 1:14.19.0-2.fc34 provided by nodejs-1:14.17.6-1.fc34.x86_64
  - package nodejs-docs-1:14.19.0-2.fc34.noarch conflicts with nodejs < 1:14.19.0-2.fc34 provided by nodejs-1:14.18.0-1.fc34.x86_64
  - package nodejs-docs-1:14.19.0-2.fc34.noarch conflicts with nodejs < 1:14.19.0-2.fc34 provided by nodejs-1:14.18.1-1.fc34.x86_64
  - package nodejs-docs-1:14.19.0-2.fc34.noarch conflicts with nodejs < 1:14.19.0-2.fc34 provided by nodejs-1:14.18.2-1.fc34.x86_64
  - cannot install the best update candidate for package yarn-1.22.17-1.noarch
  - cannot install the best update candidate for package nodejs-docs-1:14.18.3-1.fc34.noarch
  - package nodejs-1:10.24.0-1.module_f34+11492+c3e1cd8b.x86_64 is filtered out by modular filtering
  - package nodejs-1:12.21.0-2.module_f34+11529+687706f5.x86_64 is filtered out by modular filtering
  - package nodejs-1:14.15.4-1.module_f34+10907+a1534e33.x86_64 is filtered out by modular filtering
  - package nodejs-1:15.11.0-1.module_f34+11585+7d34a2e8.x86_64 is filtered out by modular filtering
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.fc34.i686
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.fc34.x86_64
  - package nodejs-1:12.22.10-1.module_f34+13763+6c79a944.x86_64 is filtered out by modular filtering
  - package nodejs-1:14.19.0-2.module_f34+13765+1c19cc08.x86_64 is filtered out by modular filtering
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.module_f34+13765+1c19cc08.x86_64
  - package nodejs-1:16.13.2-1.module_f34+13627+d44703c1.x86_64 is filtered out by modular filtering
 Problem 5: problem with installed package nodejs-1:14.18.3-1.fc34.x86_64
  - package nodejs-1:14.18.3-1.fc34.x86_64 requires nodejs-libs(x86-64) = 1:14.18.3-1.fc34, but none of the providers can be installed
  - cannot install both nodejs-libs-1:14.19.0-2.fc34.x86_64 and nodejs-libs-1:14.18.3-1.fc34.x86_64
  - cannot install both nodejs-libs-1:14.18.3-1.fc34.x86_64 and nodejs-libs-1:14.19.0-2.fc34.x86_64
  - cannot install the best update candidate for package nodejs-libs-1:14.18.3-1.fc34.x86_64
  - nothing provides /usr/bin/pwsh needed by nodejs-1:14.19.0-2.fc34.x86_64


Expected results:

Packages upgraded without problems.

Additional info:

Could be similar to https://bugzilla.redhat.com/show_bug.cgi?id=2004128.

Comment 1 Stephen Gallagher 2022-02-14 21:07:13 UTC

*** This bug has been marked as a duplicate of bug 2053637 ***


Note You need to log in before you can comment on or make changes to this bug.