Bug 2169

Summary: ptys: All network ports in use.
Product: [Retired] Red Hat Linux Reporter: niles
Component: devAssignee: David Lawrence <dkl>
Severity: high Docs Contact:
Priority: high    
Version: 6.0CC: getnito, unclei
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-04-14 13:49:26 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description niles 1999-04-13 19:46:37 UTC
I just instaled a fresh version of 5.9 and I can't telnet,
ftp or rlogin to the machine remotely.  I always get "out of
ptys" or "All network ports in use".  This is probably
related to the UNIX98 pty support in the 2.2.x kernel.
What's the work around?

Comment 1 Preston Brown 1999-04-13 20:58:59 UTC
Make sure you are mounting /dev/pts (put this in fstab):

none                    /dev/pts                devpts
mode=0620,gid=5 0 0

Comment 2 niles 1999-04-13 21:38:59 UTC
That's it!  Thanks.
Why wasn't this already in my /etc/fstab?  That seems like a bug.
oh well, perhaps something with wrong with my install.  It's working

Why can't a post this comment without "Reopen bug" getting set?
(I can't un-select it in Netscape, Bugzilla bug?)

Comment 3 Jeff Johnson 1999-04-18 17:41:59 UTC
*** Bug 2248 has been marked as a duplicate of this bug. ***

This problem is present in the latest release of RawHide,
both in the i386 and sparc architectures.

When you try to telnet or ftp into the machine with the
problem, the client program respond with the message no
network ports available. While in X windows, when trying to
open an xterm a "no pty available" message pops in the

------- Additional Comments From getnito  04/18/99 04:59 -------
Already solved in bug 2169!

The problem is solved by adding an entry for /dev/pty on /etc/fstab:

none	/dev/pts	devpts  mode=0622,gid=5       0 0

This is either a bug or a security feature in rawhide, but I thinks it
is probably a bug since it even prevent you from opening xterms in X

Comment 4 Jeff Johnson 1999-04-18 17:42:59 UTC
*** Bug 2243 has been marked as a duplicate of this bug. ***

My default starbuck installation will not run xterm or rxvt
at all.  Rxvt just chokes and dies, and xterm exits with the
xterm: no available ptys
Xiterm, on the other hand, works fine.