Bug 237211

Summary: Incorrect documentation on man page.
Product: Red Hat Enterprise Linux 5 Reporter: Wade Mealing <wmealing>
Component: bashAssignee: Tomas Janousek <tjanouse>
Status: CLOSED DUPLICATE QA Contact: Chris Ward <cward>
Severity: medium Docs Contact:
Priority: medium    
Version: 5.0   
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2007-11-06 16:17:30 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 237212    

Description Wade Mealing 2007-04-20 03:04:40 UTC
Description of problem:

Bash's ulimit -m has no effect because the kernel can not control the amount of
rss memory per process. Please update the man page to show that this option has
no effect on Linux systems.

Version-Release number of selected component (if applicable):

Any version I can find from AS2-1 to RHEL5.

How reproducible:

Every time.
Steps to Reproduce:
1. view man page.
2. search for limit, 
3. see section on -m, note that it doesn't work.
  
Actual results:

See

 -m     The maximum resident set size

Expected results:

 -m     The maximum resident set size (Has no effect on Linux systems) 


Additional info:

Jwhiter shows that the kernel or userspace applications do not adhere to this
limit in bugzilla 220657.  Upstreams bash man pages also seem to have the same
issue.

Comment 1 RHEL Program Management 2007-10-16 04:01:32 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Tomas Janousek 2007-11-06 16:17:30 UTC

*** This bug has been marked as a duplicate of 249566 ***