Bug 2731

Summary: install through ftp proxy is almost impossible
Product: [Retired] Red Hat Linux Reporter: ben
Component: installerAssignee: Matt Wilson <msw>
Severity: high Docs Contact:
Priority: medium    
Version: 6.0CC: franckrh, graham
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 1999-07-07 15:12:27 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:

Description ben 1999-05-11 10:48:45 UTC
If you try to install RH 6.0 through TIS's fwtk's ftp-gw,
then there are two major problems:

1. Using ftp@<mirror site> as the account name doesn't work.
The error is not helpful, either. Fortunately, this can be
worked around using the (undocumented) <mirror site>!ftp,
but only by reading source!

2. Setting your password to your email address doesn't work
either. The error is simply "bad response from server",
which really doesn't help much. Presumably, it is the
presence of an "@" that screws it up. Luckily, the mirror I
was using (hensa) didn't seem to mind having no password, so
I could work around this, too.

BTW, the term "FTP proxy" isn't helpful during the install -
what kind of proxy? SOCKS? HTTP? ftp-gw? Who knows?

Comment 1 Jeff Johnson 1999-05-15 21:50:59 UTC
*** Bug 2380 has been marked as a duplicate of this bug. ***

Having been unable to do so in Redhat v5.1 and v5.2, I tried
to install v6.0 using FTP via our proxy, Netscape Proxy
server v3.5.

The installer failed with the message "unknown server

A look on the console screen indicated that instead of
trying to log into the proxy with the supplied username and
password, it was trying to log into the anonymous ftp server
with the username and password.

Please fix this, having to download 450MB worth of data just
to actually install less than 100MB of it is a real waste.

------- Additional Comments From msw  04/27/99 11:23 -------
non anonymous proxy is not supported, nor is it high on the list of
things to do

------- Email Received From  Graham Leggett <minfrin> 04/27/99 11:29 -------

------- Email Received From  Ben Laurie <ben.uk> 05/15/99 17:54 -------

Comment 2 ben 1999-05-24 20:35:59 UTC
Please justify this supposed "resolution": the proxy is a perfectly
standard, anonymous fwtk FTP proxy. Is there some other proxy that
actually doesn't suffer from these problems? If so, what?

Comment 3 Derek Tattersall 1999-06-28 16:41:59 UTC
*** Bug 3685 has been marked as a duplicate of this bug. ***

This may be related to the existing FTP proxy or HTTP proxy
problems, but there is an additional piece of information.
 Despite entering a port number and proxy host on the FTP
proxy form, the installer tries to do a proxy GET to the
FTP port on the proxy.  I noticed this since our proxy
server has tcp wrappers watching the FTP port and the
connection attempt was caught.

No matter what I put for a port value on the "Further
FTP Setup" form, it still tries to talk to the FTP port on
the proxy host.

Did that make sense?

Comment 4 Jay Turner 1999-07-07 15:12:59 UTC
*** This bug has been marked as a duplicate of 2458 ***