Bug 2458 - non-anonymous ftp install can't use a password containing an "@"
non-anonymous ftp install can't use a password containing an "@"
Status: CLOSED DUPLICATE of bug 5510
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-30 21:28 EDT by Bert de Bruijn
Modified: 2007-06-06 06:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 14:18:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bert de Bruijn 1999-04-30 21:28:39 EDT
if you try to ftp-install/upgrade from a server using a
userid/password containing an "@" character, the installer
will nog be able to get stage2.img.
(the @ is considered to be the start of the hostname).

passwords containing a [TAB] character can't even be entered
in the installer dialog ([tab] switches to the next field).
Comment 1 David Lawrence 1999-05-04 14:47:59 EDT
This has been assigned to a developer for further review.
Comment 2 Jay Turner 1999-07-07 11:12:59 EDT
*** Bug 2731 has been marked as a duplicate of this bug. ***

If you try to install RH 6.0 through TIS's fwtk's ftp-gw,
then there are two major problems:

1. Using ftp@<mirror site> as the account name doesn't work.
The error is not helpful, either. Fortunately, this can be
worked around using the (undocumented) <mirror site>!ftp,
but only by reading source!

2. Setting your password to your email address doesn't work
either. The error is simply "bad response from server",
which really doesn't help much. Presumably, it is the
presence of an "@" that screws it up. Luckily, the mirror I
was using (hensa) didn't seem to mind having no password, so
I could work around this, too.

BTW, the term "FTP proxy" isn't helpful during the install -
what kind of proxy? SOCKS? HTTP? ftp-gw? Who knows?


------- Additional Comments From jbj@redhat.com  05/15/99 17:50 -------


*** Bug 2380 has been marked as a duplicate of this bug. ***

Having been unable to do so in Redhat v5.1 and v5.2, I tried
to install v6.0 using FTP via our proxy, Netscape Proxy
server v3.5.

The installer failed with the message "unknown server
response".

A look on the console screen indicated that instead of
trying to log into the proxy with the supplied username and
password, it was trying to log into the anonymous ftp server
with the username and password.

Please fix this, having to download 450MB worth of data just
to actually install less than 100MB of it is a real waste.


------- Additional Comments From msw@redhat.com  04/27/99 11:23 -------
non anonymous proxy is not supported, nor is it high on the list of
things to do


------- Email Received From  Graham Leggett <minfrin@sharp.fm> 04/27/99 11:29 -------


------- Email Received From  Ben Laurie <ben@algroup.co.uk> 05/15/99 17:54 -------


------- Additional Comments From ben@algroup.co.uk  05/24/99 16:35 -------
Please justify this supposed "resolution": the proxy is a perfectly
standard, anonymous fwtk FTP proxy. Is there some other proxy that
actually doesn't suffer from these problems? If so, what?

------- Additional Comments From dlt@redhat.com  06/28/99 12:41 -------


*** Bug 3685 has been marked as a duplicate of this bug. ***

This may be related to the existing FTP proxy or HTTP proxy
problems, but there is an additional piece of information.
 Despite entering a port number and proxy host on the FTP
proxy form, the installer tries to do a proxy GET to the
FTP port on the proxy.  I noticed this since our proxy
server has tcp wrappers watching the FTP port and the
connection attempt was caught.

No matter what I put for a port value on the "Further
FTP Setup" form, it still tries to talk to the FTP port on
the proxy host.

Did that make sense?
Comment 3 Jay Turner 2000-02-10 14:18:59 EST
*** This bug has been marked as a duplicate of 5510 ***

Note You need to log in before you can comment on or make changes to this bug.