Bug 32377

Summary: unlink error on single package install with a --prefix
Product: [Retired] Red Hat Linux Reporter: Richard Keech <rkeech>
Component: rpmAssignee: Jeff Johnson <jbj>
Status: CLOSED DUPLICATE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.1CC: nobody
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-03-20 21:17:40 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Richard Keech 2001-03-20 06:06:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i686)


Attempted installation of Applix 5.  Applix's install script failed when
loading the first
package.  The command it was attempting was
rpm -Uvh --replacefiles --prefix /opt/applix 
shelf-bin-shelf-base-2.2-315.i386.rpm

The error sent by the rpm command was:

   1:shelf-bin-shelf-base   error: can't unlink /optapplix-RPMDELETE: Is a
directory

Installation was successfull when the --prefix option was removed from the
rpm 
command line, even though the package default location was the same as that
specified by --prefix.

Reproducible: Always
Steps to Reproduce:
1.  command as shown above (I didn't try it with other packages).
2.
3.

Comment 1 Jeff Johnson 2001-03-20 15:01:15 UTC
What version of rpm? Try "rpm -q rpm" ...

Comment 2 Richard Keech 2001-03-20 21:17:36 UTC
rpm version 4.0.2-0.38

Comment 3 Jeff Johnson 2001-04-03 14:49:03 UTC
Using --prefix is the same error as using --relocate.

*** This bug has been marked as a duplicate of 25876 ***