Bug 25876 - rpm does not accept forced relocations
rpm does not accept forced relocations
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
: 32377 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-03 12:37 EST by Carlos Rodrigues
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-03 12:37:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2001-02-03 12:37:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-3 i686)


When I try to force the relocation of some package directories with
--badreloc together with --relocate <orig>=<new> it refuses to install the
package.


Reproducible: Always
Steps to Reproduce:
1. "rpm -Uvh --badreloc --relocate /usr/doc=/usr/share/doc somepackage.rpm"
where somepackage.rpm has files/directories in /usr/doc	

Actual Results:  rpm said that /usr/sharedoc conflicted with some other
package(s) already installed.

Expected Results:  It should of put the files that sould be put in
/usr/doc, in /usr/share/doc

I'm using Redhat 7.0 with the rpm-* packages from Redhat public beta
<fisher> (rpm-4.0.2)
Comment 1 Jeff Johnson 2001-04-03 09:41:54 EDT
Fixed in CVS, will be in rpm-4.0.3-0.4 and later.
Comment 2 Jeff Johnson 2001-04-03 10:48:59 EDT
*** Bug 32377 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.