Bug 32377 - unlink error on single package install with a --prefix
unlink error on single package install with a --prefix
Status: CLOSED DUPLICATE of bug 25876
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-20 01:06 EST by Richard Keech
Modified: 2013-07-03 09:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-20 16:17:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Keech 2001-03-20 01:06:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i686)


Attempted installation of Applix 5.  Applix's install script failed when
loading the first
package.  The command it was attempting was
rpm -Uvh --replacefiles --prefix /opt/applix 
shelf-bin-shelf-base-2.2-315.i386.rpm

The error sent by the rpm command was:

   1:shelf-bin-shelf-base   error: can't unlink /optapplix-RPMDELETE: Is a
directory

Installation was successfull when the --prefix option was removed from the
rpm 
command line, even though the package default location was the same as that
specified by --prefix.

Reproducible: Always
Steps to Reproduce:
1.  command as shown above (I didn't try it with other packages).
2.
3.
Comment 1 Jeff Johnson 2001-03-20 10:01:15 EST
What version of rpm? Try "rpm -q rpm" ...
Comment 2 Richard Keech 2001-03-20 16:17:36 EST
rpm version 4.0.2-0.38
Comment 3 Jeff Johnson 2001-04-03 10:49:03 EDT
Using --prefix is the same error as using --relocate.

*** This bug has been marked as a duplicate of 25876 ***

Note You need to log in before you can comment on or make changes to this bug.