Bug 32665

Summary: recent update of db3 pages broke perl's use DB_File
Product: [Retired] Red Hat Linux Reporter: Landon Curt Noll <redhat-mail>
Component: perlAssignee: Crutcher Dunnavant <crutcher>
Status: CLOSED ERRATA QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 7.0   
Target Milestone: ---   
Target Release: ---   
Hardware: i386   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2001-04-03 11:00:20 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Description Landon Curt Noll 2001-03-22 04:20:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14 i686)


Recently RH published updates to db3-3.1.17-5.i386.rpm,
db3-devel-3.1.17-5.i386.rpm and db3-utils-3.1.17-5.i386.rpm.

After performing these updates, perl's DB_File package broke.

Reproducible: Always
Steps to Reproduce:
1.Create the executable file ./tmp/y containing:

#!/usr/bin/perl -w
use DB_File;
print "It worked.\n";

2.execute /tmp/y
3.observe the result
	

Actual Results:  
DB_File needs compatible versions of libdb & db.h
	you have db.h version 3.1.14 and libdb version 3.1.17
Compilation failed in require at /tmp/y line 2.
BEGIN failed--compilation aborted at /tmp/y line 2.


Expected Results:  It worked.

I also tried:

	cd /usr/include
	h2ph db.h
	h2ph db3/db.h

without success.
Comment 1 Landon Curt Noll 2001-03-23 18:57:30 EST
If you download and install the recent DB_File CPAN module, it
compiles with the newer db3 release and works.

Perhaps RH should produce a db3_perl module and move the
perl db code to there?  When db3 is changed, the db3_perl
module could also be updated ...
Comment 2 James Brents 2001-03-24 00:18:02 EST
This was probably just oversight on RH's part, and the fact im sure they dont
want to release a new version of perl when alls required is a recompilation.
Easy solution is just use the perl source RPM and --rebuild and install that,
After you've upgraded db3 of course. Solved my problems, Though an actual
updated perl package would be nice..
Comment 3 Nalin Dahyabhai 2001-04-03 11:00:17 EDT
*** Bug 32818 has been marked as a duplicate of this bug. ***
Comment 4 Crutcher Dunnavant 2001-04-03 12:07:15 EDT
and an actual updated perl package is coming...
Comment 5 Nalin Dahyabhai 2001-04-05 16:17:34 EDT
*** Bug 33674 has been marked as a duplicate of this bug. ***