This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 32818 - db.h error with db3 errata
db.h error with db3 errata
Status: CLOSED DUPLICATE of bug 32665
Product: Red Hat Linux
Classification: Retired
Component: db3 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-23 09:32 EST by Christian Rose
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 09:32:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2001-03-23 09:32:15 EST
Upgrading a RH7 box with the db3 update in
http://www.redhat.com/support/errata/RHEA-2001-015.html broke a custom
perl application here. Installed packages were:

db1-1.85-4
db1-devel-1.85-4
db2-2.4.14-4
db3-3.1.17-5
db3-devel-3.1.17-5
db3-utils-3.1.17-5

and the perl error was:

DB_File needs compatible versions of libdb & db.h
        you have db.h version 3.1.14 and libdb version 3.1.17

But db3-devel-3.1.17-5 should provide the correct db.h
(/usr/include/db3/db.h and the symlink /usr/include/db.h)!
Anyway, reverting to the 3.1.14-6 versions of the db3 packages (from
stock RH7) solved the problems. But it seems there is something strange
with the db3-*3.1.17-5* packages from the errata.
Comment 1 Nalin Dahyabhai 2001-04-03 11:00:21 EDT
Perl problem.  We're prepping an errata for it.

*** This bug has been marked as a duplicate of 32665 ***

Note You need to log in before you can comment on or make changes to this bug.