Bug 32665 - recent update of db3 pages broke perl's use DB_File
Summary: recent update of db3 pages broke perl's use DB_File
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 32818 33674 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-22 09:20 UTC by Landon Curt Noll
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-03 15:00:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2001:043 normal SHIPPED_LIVE db3 update broke perl's DB_File module. 2001-04-03 04:00:00 UTC

Description Landon Curt Noll 2001-03-22 09:20:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14 i686)


Recently RH published updates to db3-3.1.17-5.i386.rpm,
db3-devel-3.1.17-5.i386.rpm and db3-utils-3.1.17-5.i386.rpm.

After performing these updates, perl's DB_File package broke.

Reproducible: Always
Steps to Reproduce:
1.Create the executable file ./tmp/y containing:

#!/usr/bin/perl -w
use DB_File;
print "It worked.\n";

2.execute /tmp/y
3.observe the result
	

Actual Results:  
DB_File needs compatible versions of libdb & db.h
	you have db.h version 3.1.14 and libdb version 3.1.17
Compilation failed in require at /tmp/y line 2.
BEGIN failed--compilation aborted at /tmp/y line 2.


Expected Results:  It worked.

I also tried:

	cd /usr/include
	h2ph db.h
	h2ph db3/db.h

without success.

Comment 1 Landon Curt Noll 2001-03-23 23:57:30 UTC
If you download and install the recent DB_File CPAN module, it
compiles with the newer db3 release and works.

Perhaps RH should produce a db3_perl module and move the
perl db code to there?  When db3 is changed, the db3_perl
module could also be updated ...

Comment 2 James Brents 2001-03-24 05:18:02 UTC
This was probably just oversight on RH's part, and the fact im sure they dont
want to release a new version of perl when alls required is a recompilation.
Easy solution is just use the perl source RPM and --rebuild and install that,
After you've upgraded db3 of course. Solved my problems, Though an actual
updated perl package would be nice..

Comment 3 Nalin Dahyabhai 2001-04-03 15:00:17 UTC
*** Bug 32818 has been marked as a duplicate of this bug. ***

Comment 4 Crutcher Dunnavant 2001-04-03 16:07:15 UTC
and an actual updated perl package is coming...

Comment 5 Nalin Dahyabhai 2001-04-05 20:17:34 UTC
*** Bug 33674 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.