Bug 359771

Summary: phy0 -> rt2x00pci_write_tx_data: Error - Arrived at non-free entry in the non-full queue 2.
Product: [Fedora] Fedora Reporter: David Nielsen <gnomeuser>
Component: kernelAssignee: John W. Linville <linville>
Status: CLOSED CURRENTRELEASE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: bryan.christ, cebbert, davej, dzrudy, ivdoorn, mats.ljunggren, milan.kerslager
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: 2.6.23.12-99.fc8 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-01-09 15:46:17 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
Bug Depends On:    
Bug Blocks: 235704    

Description David Nielsen 2007-10-31 04:19:29 EDT
Description of problem:
I'm seeing two problems with my rt61pci wireless right now, often it will
repeatedly timeout connecting to the AP when it does correctly connect I see
this spammed in dmesg over and over again.

Please file bug report to http://rt2x00.serialmonkey.com.
phy0 -> rt2x00pci_write_tx_data: Error - Arrived at non-free entry in the
non-full queue 2.

Version-Release number of selected component (if applicable):
kernel-2.6.23.1-41.fc8

How reproducible:


Steps to Reproduce:
1. attempt to have NM connect to AP
2. If connection isn't timed out for no good reason 
  
Actual results:
Notice convinient spamming of logs with request for a bugreport

Expected results:
Connection to my AP on every boot up, no fail and keep my logs quiet unless
something is actually wrong.

Additional info:
Comment 1 John W. Linville 2007-10-31 09:37:36 EDT
These kernels have some wireless updates not yet in the -41 kernel you are 
testing:

   http://koji.fedoraproject.org/koji/taskinfo?taskID=218502

Would you mind trying to reproduce the issue with those kernels?  Does it 
reappear?
Comment 2 David Nielsen 2007-10-31 10:06:17 EDT
I could successfully reconnect to the wireless after several warm boots, however
after a cold boot I could not connect to the AP again without restarting Network
Manager a few times.

All in all this is a fantastic improvement so far, the success rate has gone up
dramatically and so far I have not seen the error message.
Comment 3 John W. Linville 2007-11-09 14:26:21 EST
Please try these kernels:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=23734

Are they working satisfactorily for you?
Comment 4 David Nielsen 2007-11-09 21:48:14 EST
I've been running that for a good 18 hours now, so far it's the best kernel for
my wifi. It will still occasionally go into a state where it will claim that the
 progress of connecting to and getting an IP from the AP times out, this happens
most commonly when using WPA.

Also this:
phy0 -> rt2x00pci_write_tx_data: Error - Arrived at non-free entry in the
non-full queue 2.

Popped back up in the logs. So we aren't perfect yet but it's far closer to
being usable now.
Comment 5 John W. Linville 2007-11-29 09:47:50 EST
A patch that was reported to fix this problem has been included in 
kernel-2.6.23.8-63.fc8.  Could you test that kernel and confirm whether or not 
it fixes the problem for you?
Comment 6 Dawid Zamirski 2007-12-06 20:53:08 EST
John,

I'm getting similar error with kernel-2.6.23.8-63.fc8 and rt73usb (Linksys
WUSB54GC):

phy0 -> rt2x00usb_write_tx_data: Error - Arrived at non-free entry in the
non-full queue 2

Also, I got a few of those in messages log:
Dec  6 19:23:41 nufin kernel: phy0 -> rt2x00usb_vendor_request: Error - Vendor
Request 0x07 failed for offset 0x3040 with error -19.

When I pull out the NIC and then plug it back in, the connection seems to be
stable. 
Comment 7 Mats Ljunggren 2007-12-08 03:54:52 EST
I'm running kernel-2.6.23.8-63.fc8 and have a wireless NIC which uses the
rt61pci device driver. I get a lot of "phy0 -> rt2x00pci_write_tx_data: Error -
Arrived at non-free entry in the non-full queue 2." entries in the messages log
file with a very high rate. I counted the number of new messages I got in 10
seconds, and they were roughly 100.
Comment 8 Milan Kerslager 2007-12-18 03:47:32 EST
I have RaLink RT2561/RT61 802.11g PCI card. I'm loosing connection since
kernel-2.6.23.1-42.fc8 kernel. I tryed kernel-2.6.23.8-63.fc8 kernel with no luck.
Comment 10 John W. Linville 2008-01-02 12:04:54 EST
*** Bug 426874 has been marked as a duplicate of this bug. ***
Comment 11 John W. Linville 2008-01-02 14:40:48 EST
Please try a later .fc8 kernel, one that includes the patch Ivo cited in 
comment 9 above:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=28665

Does that correct the issue for you?
Comment 12 Dawid Zamirski 2008-01-03 21:52:07 EST
It works for me since kernel-2.6.23.9-85.fc8 - I havn't tested the 99th build
from koji yet.
Comment 13 Bryan Christ 2008-01-04 16:02:33 EST
I would be glad to retest this on my system, but I am currently blocked from
doing so by another rt2x00 issue (buzilla 411481).
Comment 14 Mats Ljunggren 2008-01-09 14:35:33 EST
I have now run kernel-2.6.23.12-99.fc8 for two days. I see no huge number of 
messages any longer. However, I still have a problem I had before. The link 
speed starts at 54 Mbps, but suddenly drops and goes down to 1 Mbps and stays 
there even though the link quality is good. I should mention that I only have 
about 5 meters between my wlan router and client, so I expect to have quite 
high link speed.
Comment 15 Ivo van Doorn 2008-01-09 15:37:44 EST
Sounds like bug #382781

try setting your configuration to a fixed rate.
Comment 16 John W. Linville 2008-01-09 15:46:17 EST
...and report any further link speed problems there, please. :-)

I'm going to optimistically close this based on comment 14.  Please reopen if 
the problem can be recreated with -99.fc8 or later.