Bug 407631

Summary: Elisa doesn't display anything in Fedora 8
Product: [Fedora] Fedora Reporter: Matt Wringe <mwringe>
Component: libxcbAssignee: Adam Jackson <ajax>
Status: CLOSED WONTFIX QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: 8CC: aj, drussell, kontakt, libbe, ma, matthias, mrhodes, patrick, sandmann
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-08-26 10:41:25 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
this is elisa dbg log
none
gdb log from pigment svn version none

Description Matt Wringe 2007-12-01 21:58:07 EST
Description of problem:
When elisa is run in Fedora 8 nothing gets displayed. 

Version-Release number of selected component (if applicable):
elisa-0.3.2-1.fc8

How reproducible:
Always. On both x86 and x86_64 fedora versions

Steps to Reproduce:
1. yum install elisa
2. elisa
  
Actual results:
The following gets displayed on the screen and elisa cannot be stopped by using
ctrl-c:
WARN  MainThread      plugin_registry             Dec 02 02:56:20  Un-met
dependency for flickr_media: twill (elisa/core/plugin_registry.py:198)
WARN  MainThread      plugin_registry             Dec 02 02:56:20  Un-met
dependency for bluetooth_input: bluetooth (elisa/core/plugin_registry.py:198)
WARN  MainThread      plugin_registry             Dec 02 02:56:20  Un-met
dependency for stage6: BeautifulSoup (elisa/core/plugin_registry.py:195)
WARN  MainThread      comp_hal_service            Dec 02 02:56:20  Could not
connect to the Gnome ScreenSaver: org.freedesktop.DBus.Error.ServiceUnknown: The
name org.gnome.ScreenSaver was not provided by any .service files
(elisa/plugins/good/hal/hal_service.py:107)
WARN  MainThread      plugin_registry             Dec 02 02:56:20  Component
fspot_media failed to initialize: FSpot DB not found at
'/root/.gnome2/f-spot/photos.db' (elisa/core/plugin_registry.py:618)
WARN  MainThread      plugin_registry             Dec 02 02:56:20  Component
'flickr:flickr_media' not found (elisa/core/plugin_registry.py:618)
WARN  MainThread      plugin_registry             Dec 02 02:56:20  Plugin
'stage6' not found (elisa/core/plugin_registry.py:455)
WARN  MainThread      plugin_registry             Dec 02 02:56:20  Component
'stage6:stage_media' not found (elisa/core/plugin_registry.py:618)
WARN  MainThread      comp_audio_activity         Dec 02 02:56:20  XDG user-dir
disabled (elisa/plugins/base/activities/media_menu_activity.py:424)
WARN  MainThread      comp_video_activity         Dec 02 02:56:20  XDG user-dir
disabled (elisa/plugins/base/activities/media_menu_activity.py:424)
WARN  MainThread      comp_image_activity         Dec 02 02:56:20  XDG user-dir
disabled (elisa/plugins/base/activities/media_menu_activity.py:424)
elisa: could not connect to socket
elisa: No such file or directory
WARN  MainThread      plugin_registry             Dec 02 02:56:20  Component
lirc_input failed to initialize: Unable to initialize lirc!
(elisa/core/plugin_registry.py:618)

Expected results:
elisa should start running
Comment 1 Martin Jürgens 2007-12-08 18:32:50 EST
same for me. i already downloaded elisa from the fluendo site, and it also does
not work.
Comment 2 Harry Waye 2007-12-09 12:03:10 EST
same as above.
Comment 3 Matthias Saou 2007-12-10 04:43:06 EST
Strange, it works fine for me. Do you have hardware accelerated 3D working?
Because right after that lirc message, I have the pigment lines :

WARN  MainThread      comp_pigment_context        Dec 10 10:42:14  Compiz
detected, trying to hide all other windows.
(elisa/plugins/good/pigment/pigment_context.py:171)
WARN  MainThread      comp_pigment_context        Dec 10 10:42:14  Could not
import WNCK. Windows hiding disabled.
(elisa/plugins/good/pigment/pigment_context.py:175)

And then the main elisa window pops-up fine...
Comment 4 Martin Jürgens 2007-12-10 07:08:19 EST
Hi. I compiled from source and it worked one time. Then it crashed and never
worked again - like the RPMs in Fedora.

Yes, I have hardware accelerated 3D using the nvidia proprietary driver.

This is my output with a not existant ~/.elisa:

bash-3.2$ elisa
WARN  MainThread      plugin_registry             Dez 10 13:06:30  Un-met
dependency for flickr_media: twill (elisa/core/plugin_registry.py:198)
WARN  MainThread      plugin_registry             Dez 10 13:06:30  Un-met
dependency for bluetooth_input: bluetooth (elisa/core/plugin_registry.py:198)
WARN  MainThread      plugin_registry             Dez 10 13:06:31  Component
'flickr:flickr_media' not found (elisa/core/plugin_registry.py:618)
elisa: could not connect to socket
elisa: Datei oder Verzeichnis nicht gefunden
WARN  MainThread      plugin_registry             Dez 10 13:06:32  Component
lirc_input failed to initialize: Unable to initialize lirc!
(elisa/core/plugin_registry.py:618)
Comment 5 Martin Jürgens 2007-12-10 07:15:25 EST
Created attachment 282701 [details]
this is elisa dbg log
Comment 6 Patrick Steiner 2007-12-10 08:06:35 EST
i also can confirm this problem.

i have tested it on 3 different machines, all running latest version of fedora 8.

i also can reproduce this problem:
https://code.fluendo.com/pigment/trac/ticket/186

Comment 7 Patrick Steiner 2007-12-10 08:16:42 EST
Created attachment 282751 [details]
gdb log from pigment svn version

now i used pigment svn version and libxcb 1.1 from fedora 9 (koji).

i attached a gdb log.
Comment 8 Matthias Saou 2007-12-10 08:21:03 EST
So this seems to be a libxcb bug. Reassigning and CC'ing Soren.

freedesktop bug report : https://bugs.freedesktop.org/show_bug.cgi?id=12511
Comment 9 Jakub 'Livio' Rusinek 2007-12-15 08:47:16 EST
Don't know why, but Elisa is showing for me like a price in lottery - only
sometimes. I have no issues with displays...

Elisa also starts drawing interface when it's running minimum 1 minute long.
Also, don't know why.

Only know one thing: Elisa is strange piece of software and it has big problems
with drawing and starting.
Comment 10 Patrick Steiner 2007-12-15 11:45:34 EST
i have test elisa with a ubuntu-7.10 live-cd. and there it works out of the box.

so this must be a fedora specific bug.
Comment 11 Matthias Saou 2008-01-17 07:38:02 EST
Reassigning to the component (libxcb) owner, oops!
Comment 12 Johan Kok 2008-01-19 04:37:14 EST
*** Bug 425856 has been marked as a duplicate of this bug. ***
Comment 13 Jakub 'Livio' Rusinek 2008-01-19 06:45:13 EST
It works in openSUSE 10.3 too.
Comment 14 Dave Russell 2008-01-19 07:00:48 EST
Just to note, still broken with libxcb-1.0-4.fc8, also didn't work with
libxcb-1.1-1.fc9.i386.rpm.

Elisa version 0.3.2
Comment 15 Jakub 'Livio' Rusinek 2008-01-19 09:08:19 EST
What is Xcb?
Comment 16 David Cartwright 2008-01-22 00:50:54 EST
Checking if there is an expected fix date for this problem?

Elisa looks like a great product that will open a range of new opportunities for
Fedora, so would be great to have it running on Fedora 8.
Comment 17 Jakub 'Livio' Rusinek 2008-01-22 09:16:16 EST
I've tested 0.3.3 on my own (using make install, I know, stupid method) and I
dislike it... Slower than ever...

But it works. Even when some notification window covers Elisa, it doesn't stop
drawing its UI.
Comment 18 Martin Jürgens 2008-01-22 16:18:58 EST
0.3.3 does not work for me, either.
Comment 19 Matthias Saou 2008-01-23 04:37:21 EST
ajax or sandmann, could you please have a look? Here are the relevant URLs again :
https://bugs.freedesktop.org/show_bug.cgi?id=12511 (says it's fixed in git)
http://lists.freedesktop.org/archives/xcb/2007-October/003019.html (details)
Comment 20 Martin Jürgens 2008-01-23 10:25:42 EST
My first problem with 0.3.3 was caused by pysqlite2  not being installed. Now,
when having it installed, I get the same issue:

[martin@medora ~]$ LC_ALL=C elisa
WARN  MainThread      media_manager               Jan 23 16:21:00  Un-met
dependency for flickr:flickr_media: twill (elisa/core/manager.py:95)
elisa: could not connect to socket
elisa: No such file or directory
WARN  MainThread      interface_controller        Jan 23 16:21:00  Component
lirc_input failed to initialize: Unable to initialize lirc!
(elisa/core/interface_controller.py:324)


I noticed that libxcb 1.0-4 contains a patch which may be intended to fix the
problem:

* Tue Dec 04 2007 Soren Sandmann <sandmann@redhat.com> 1.0-4
- libxcb-1.0-lock-asserts.patch, see bug 11390.

but it obvisiously does not work. I also tried the version in Koji for f9, but
it did not work either. Maybe a third person could try elisa 0.3.3?
Comment 21 Andreas-Johann Ulvestad 2008-01-25 17:24:37 EST
I can confirm this problem on x86_64 using Fedora 8 with latest updates. Tried
fedora RPMs and newest vanilla source, same result on both. Using nvidia drivers.
Comment 22 Martin Jürgens 2008-01-25 17:46:26 EST
I am also using the NVIDIA closed source driver. I will now try an open 3D
driver to see if it works.
Comment 23 Jakub 'Livio' Rusinek 2008-01-25 17:49:00 EST
ATI Radeon 9250 @ open. Doesn't work too.
Comment 24 Martin Jürgens 2008-01-25 17:56:05 EST
does not work with openchrome either
Comment 25 Torsten Trautwein 2008-02-29 00:43:04 EST
I've got the same problem with intel GMA950 graphics using the X.org intel driver.
Comment 26 Martin Jürgens 2008-03-15 20:22:11 EDT
I just compiled version 0.3.5 by hand and it works fine now (while with previous
releases, this did not work). May be worth packaging.
Comment 27 Jakub 'Livio' Rusinek 2008-03-16 03:48:14 EDT
It is always worth packaging to keep package up to date :) .

Martin, you've used configure/make/make install method or you've made RPM?
Comment 28 Martin Jürgens 2008-03-16 07:27:11 EDT
I've used used configure/make/make.
Comment 29 Jakub 'Livio' Rusinek 2008-03-16 08:06:53 EDT
It works well.

PS: I really need new hardware... Tomorrow new GPU will be mine ^^ .
Comment 30 Matthias Saou 2008-08-26 10:41:25 EDT
Sorry folks, but the 0.3 elisa codebase probably won't ever be updated again, and the 0.5 packages are still pending review of the new separate plugins packages as well as the Twisted web2 package.

So I'll close this bug report... Please check out bug #429590 to track the elisa update, there are links in there to some testing 0.5 packages which you can use for now.

If the problem is still present in 0.5, it obviously can't yet be fixed in Fedora itself, so please do also file a bug report upstream for the developers to take care of it, thanks.