Bug 429590 - Update elisa
Update elisa
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: elisa (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
: 437269 452460 473778 485863 488349 (view as bug list)
Depends On: 429112 438608 438609
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 15:47 EST by Jakub 'Livio' Rusinek
Modified: 2009-03-09 19:16 EDT (History)
19 users (show)

See Also:
Fixed In Version: 0.5.30-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-09 18:48:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
elisa error log (3.68 KB, text/plain)
2008-10-04 06:15 EDT, Valent Turkovic
no flags Details

  None (edit)
Description Jakub 'Livio' Rusinek 2008-01-21 15:47:21 EST
Description of problem:
0.3.3 released on 16th januar, while 0.3.2 in repo.
Comment 1 Matthias Saou 2008-01-22 05:16:35 EST
Two problems :

- The new YouTube plugin is shipped as a pre-compiled i386 binary plugin, which
is obviously not acceptable for Fedora. See
http://lists.fluendo.com/pipermail/elisa/2008-January/000373.html - I think
it'll have to be removed/disabled for now... it'll be in the ugly or bad
gstreamer plugins anyway, so not in Fedora anytime soon.

- The pigment python bindings have been split out, and the new pigment-python
package is still pending review (it's bug #429112). The review needs to be done
before I can proceed with the update.
Comment 2 Jakub 'Livio' Rusinek 2008-03-01 10:14:32 EST
pigment-python built. you can continue.

when building, try to build 0.3.3 for F-8 for me, please :) .
Comment 3 Ola Thoresen 2008-03-08 13:15:51 EST
Just a heads up - 0.3.4 is now released.
Comment 4 Jakub 'Livio' Rusinek 2008-03-08 13:32:25 EST
"0.3.4 release candidate"
Comment 5 Ola Thoresen 2008-03-13 15:16:02 EDT
My bad.
But NOW - "Elisa 0.3.5 is out!"
http://elisa.fluendo.com/2008/03/12/elisa-new-releases/
=;-)

Rgds
Comment 6 Jakub 'Livio' Rusinek 2008-03-13 15:53:33 EDT
Quick development, isn't it :) ?
Comment 7 Matthias Saou 2008-03-22 18:18:57 EDT
*** Bug 437269 has been marked as a duplicate of this bug. ***
Comment 8 Matthias Saou 2008-03-22 18:21:09 EDT
I've got 0.3.5 packages ready, but in order to push the update, the
elisa-plugins-good and elisa-plugins-bad packages will need to be reviewed...
Comment 9 Jakub 'Livio' Rusinek 2008-03-22 18:34:32 EDT
elisa-plugins-ugly will probably land in Livna/RPM Fusion.

Am I right?
Comment 10 Thomas Vander Stichele 2008-04-18 17:24:44 EDT
Matthias, where are your packages for review ?
Comment 11 Thomas Vander Stichele 2008-04-19 04:27:05 EDT
Ok, they're now in Matthias's review directory.

I think elisa is missing a pyxdg dependency - see #1206 in elisa's trac.
Comment 12 Martin Jürgens 2008-05-27 12:46:06 EDT
Where can I find Matthias' review directory? Thanks
Comment 13 Matthias Saou 2008-05-27 13:32:29 EDT
(In reply to comment #12)
> Where can I find Matthias' review directory? Thanks

Here : http://thias.fedorapeople.org/review/
Comment 14 Matthias Saou 2008-06-23 04:55:43 EDT
*** Bug 452460 has been marked as a duplicate of this bug. ***
Comment 15 Matthias Saou 2008-07-30 04:48:41 EDT
Note that I've been keeping the package updated (outside of Fedora, since the
requirements still require reviewing), it's now at 0.5.3 :
http://thias.fedorapeople.org/review/elisa/

Because some new requirements keep popping up, things aren't easy, but the
packages available here currently work on Fedora 9 :
http://ftp.freshrpms.net/pub/freshrpms/fedora/linux/testing/9/elisa/
Comment 16 Dave Russell 2008-07-30 07:45:25 EDT
First of all, glad to hear you're keeping the packages updated, even if they're
outside of Fedora currently...

However, I've just tried the rpms from
http://ftp.freshrpms.net/pub/freshrpms/fedora/linux/testing/9/elisa/ on a fully
updated F9 i386 box, and while they install fine, when I actually run it, there
is no display, just a black screen.

I briefly see the interface fade in, and then it just stays black. Pressing ESC
twice gets me out.
Comment 17 Matthias Saou 2008-07-30 08:30:28 EDT
Strange. I haven't tested the very latest packages on i386, only x86_64 with the
binary nvidia driver and compiz disabled, and that works. Obviously, your
mileage does vary. Launch it from a terminal and check the output, then to debug
further you should check the possible pigment env variables and/or make sure
your OpenGL setup works okay... there is also an IRC channel where you could ask
for help.
Comment 18 Dave Russell 2008-07-30 08:53:10 EDT
Ahh, and there's the rub!

Disabling compiz made the difference.

Nothing obvious from the terminal output but once compiz was disabled it fired
up just fine.

I take it still no luck on getting those packages reviewed?
Comment 19 Matthias Saou 2008-07-30 09:08:50 EDT
(In reply to comment #18)
> I take it still no luck on getting those packages reviewed?

No luck at all... but feel free to step up or poke someone who could :-)
Comment 20 Harry Waye 2008-07-31 12:22:30 EDT
Tested your packages with intel and ati xorg drivers and had to set vblank_mode
to 0 in .drirc, otherwise I would get very slow frame rates.  I guess this is a
problem in mesa packages though.  After that though its all good.  Thanks very much.
Comment 21 Matthias Saou 2008-08-26 10:46:18 EDT
Just FYI, I keep all of the elisa packages updated in the locations mentioned in the various reviews, as well as at this temporary URL :

http://ftp.freshrpms.net/pub/freshrpms/fedora/linux/testing/9/elisa/
(currently at 0.5.7)

The arch specific directories are yum repos, too. Feel free to test and report packaging related problems in the corresponding review bugzilla entries.
Comment 22 Ola Thoresen 2008-08-26 12:32:31 EDT
FWIW I've used your packages for a month or so, and they work fine here.
x86_64 with F9, Nvidia Geforce 6200.

I must say I'm impressed with Elisa. Even if there are still some features missing, it works nice as a media player. And I really love that it does not hijack the entire machine, like other mediacenter-software usually do (replacing lots of libraries and packages, causing all kinds of conflicts and issus).
Comment 23 Matthias Saou 2008-09-15 08:09:38 EDT
Note that the latest pigment update has broken elisa. This should be fixed with the release of 0.5.10 tomorrow. Until then, manually downgrading to the pervious pigment and pigment-python packages works.
Comment 24 Valent Turkovic 2008-10-04 06:11:59 EDT
I have Fedora 9 and all latest updates installed - elisa doesn't start, it crashes. I believe this is a bug that should go separetely but if you update it then it probably becomes obsolete so that is why I'm posting it here.
Comment 25 Valent Turkovic 2008-10-04 06:14:08 EDT
I don't even see the updated elisa in testing repositories, that is strange.
Comment 26 Valent Turkovic 2008-10-04 06:15:20 EDT
Created attachment 319453 [details]
elisa error log

this is what I get when I try to start elisa
Comment 27 Valent Turkovic 2008-10-04 07:15:36 EDT
I tried installing elisa from freshrpms testing repositories but I seem to be stuck. I can't install pigment-python-0.3.8-1.fc9.i386.rpm because it needs these missing dependencies:
libpigment-0.3.so.8
libpigment-gtk-0.3.so.8
libpigment-imaging-0.3.so.8

and elisa plugins need pigment-python package.

Please help.
Comment 28 Valent Turkovic 2008-10-04 08:01:46 EDT
I just installed elisa on Fedora 10 beta hoping that there will be an updated version but it is also old 0.3.2 version of elisa.

Please provide some testing packages in rawhide so we can test it.

TIA!
Comment 29 Harry Waye 2008-10-04 16:06:34 EDT
The libraries pigment-python requires are (should be) supplied by the pigment package.  The freshrpms packages work fine here with f9.
Comment 30 Valent Turkovic 2008-10-04 16:34:39 EDT
I wrote a detailed blog post:
http://kernelreloaded.blog385.com/index.php/archives/fur-elise-not-on-fedora/

the issue is that pigment-python-0.3.8-1.fc9.i386.rpm but that packet needs libpigment-0.3.so.8, libpigment-gtk-0.3.so.8 and libpigment-imaging-0.3.so.8 but pigment-devel-0.3.9-1.fc9.i386.rpm packet provides only so.7 but no so.8 libraries…
Comment 31 Valent Turkovic 2008-10-05 09:25:05 EDT
I got an answer on my blog:

Peter wrote:
elisa isn in F-10 as there are two elisa-plugins-[good|bad] package reviews that need to be done before it can be upgraded. If someone gets them done for F-10 no doubt it can be in there!
Comment 32 Matthias Saou 2008-10-07 08:24:10 EDT
(In reply to comment #31)
> I got an answer on my blog:
> 
> Peter wrote:
> elisa isn in F-10 as there are two elisa-plugins-[good|bad] package reviews
> that need to be done before it can be upgraded. If someone gets them done for
> F-10 no doubt it can be in there!

Exactly. But no reviewers seem interested, which happens.
Comment 33 Dave Russell 2008-10-07 23:38:32 EDT
I'd really like to see this arrive in F10, and while I'm not currently able to get involved... I'm going to try and poke some people who might have some cycles to spare on reviewing this.

Don't loose heart!
Comment 34 Jóhann B. Guðmundsson 2008-10-10 04:10:15 EDT
Any news/updates?

We will be testing https://fedoraproject.org/wiki/Features/BetterLIRCSupport
on 2008-10-16 see https://fedoraproject.org/wiki/QA/Test_Days for details

It would great if testers would be able to test and play in a media center
at a same time.
Comment 35 Peter Robinson 2008-10-10 05:10:05 EDT
(In reply to comment #34)
> Any news/updates?

As stated before it depends on package reviews of new dependent packages getting done. Feel free to join the fun fun fun :) I might be able to get some done over the weekend but they do take time.
Comment 36 Matthias Saou 2008-10-10 08:33:10 EDT
I've updated elisa to 0.5.13 in CVS for the devel branch, instead of tracking updates outside.

* Fri Oct 10 2008 Matthias Saou <http://freshrpms.net/> 0.5.13-2
- Go back to using an elisa/elisa-base split, we'll just BR elisa-base in
  the plugins.

Note also that the unofficial Fedora packages are now available here :
http://people.fluendo.com/matthias/elisa/
(the freshrpms.net location should be phased out soon)
Comment 37 Jóhann B. Guðmundsson 2008-11-05 05:43:00 EST
Matthias can you make these packages available for F10 and in rpmfusion
until this paperwork issue gets resolved.
Comment 38 Bug Zapper 2008-11-26 04:31:14 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 39 Dave Russell 2008-11-26 08:34:30 EST
I'm updating this to F10 as the issue is still relevant here.
Comment 40 Matthias Saou 2008-12-01 05:14:55 EST
*** Bug 473778 has been marked as a duplicate of this bug. ***
Comment 41 Valent Turkovic 2008-12-01 05:55:03 EST
Just to confirm. Just installed elisa.3.2-1.fc8 (strange it has fc8 in the package name) on Fedora 10 and this is what you get when trying to start it:  

$ elisa
Traceback (most recent call last):
  File "/usr/bin/elisa", line 8, in <module>
    load_entry_point('elisa==0.3.2', 'gui_scripts', 'elisa')()
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 277, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 2179, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 1912, in load
    entry = __import__(self.module_name, globals(),globals(), ['__name__'])
  File "/usr/lib/python2.5/site-packages/elisa/core/application.py", line 48, in <module>
    from twisted.web import client
ImportError: No module named web
Comment 42 Dave Russell 2008-12-01 07:31:24 EST
(In reply to comment #41)
> Just to confirm. Just installed elisa.3.2-1.fc8 (strange it has fc8 in the
> package name) on Fedora 10 and this is what you get when trying to start it:  

That's because the package hasn't been rebuilt for some time in Fedora, there are a number of dependencies that aren't in the default Fedora repos.

You'll need to use the updated packages from the repo listed below:

http://people.fluendo.com/matthias/elisa/

The package reviews are ongoing, but I don't see this being solved quickly... I think it's really time to rethink getting this into Fedora, maybe it's better positioned in RPMFusion?
Comment 43 Alex Lancaster 2008-12-14 03:36:50 EST
Since elisa was already broken in rawhide because of the Python 2.6, I rebuilt the main elisa package but it appears to depend on the plugins also being packaged as per comment #8:

Broken deps for i386
----------------------------------------------------------
	elisa-0.5.20-1.fc11.noarch requires elisa-plugins-good = 0:0.5.20
	elisa-0.5.20-1.fc11.noarch requires elisa-plugins-bad = 0:0.5.20
Comment 44 Peter Robinson 2008-12-14 07:45:14 EST
If someone is interested in doing a couple of fairly simple reciprocal reviews, now that the twisted stuff is in I can do both -good and -bad in the next day or so.
Comment 45 Silvio Schneider 2009-02-07 11:15:05 EST
I can confirm Comment #41 Elisa does not start on fedora 10! :-(
Comment 46 Silvio Schneider 2009-02-07 11:20:23 EST
This packages
yum install python-twisted-web
yum install python-louie
does not solves Comment #41. It solves the dependencies but gives an new
error:
A problem occurred in Elisa.
/tmp/elisa_yT4ELw.txt contains the description of this error.

The content of this file is some python error stuff.
Comment 47 Ola Thoresen 2009-02-07 11:30:58 EST
Just yesterday I used the src.rpms from http://people.fluendo.com/matthias/elisa/ and the source.tar.gz-files from http://elisa.fluendo.com/download and created 0.5.26-rpms.
No tweaking is neccessary to get the rpms rebuilt (except from changing the version-string in the .spec-file.

From elisa version 0.5.25 updates are distributed via the internal plugin system, so you do not depend on packages any more (although I think new packages should be built for fedora this solves my immediate problem).

Rgds
Comment 48 Silvio Schneider 2009-02-07 11:47:47 EST
These rpms gives me a dependency deadlock:

[root@tower2 Programme]# rpm -Uvh elisa-plugins-good-0.5.23-1.fc9.noarch.rpm 
warning: elisa-plugins-good-0.5.23-1.fc9.noarch.rpm: Header V4 DSA signature: NOKEY, key ID e42d547b
error: Failed dependencies:
	elisa = 0.5.23 is needed by elisa-plugins-good-0.5.23-1.fc9.noarch
[root@tower2 Programme]# rpm -Uvh elisa-0.5.23-1.fc9.noarch.rpm 
warning: elisa-0.5.23-1.fc9.noarch.rpm: Header V4 DSA signature: NOKEY, key ID e42d547b
error: Failed dependencies:
	elisa-plugins-bad = 0.5.23 is needed by elisa-0.5.23-1.fc9.noarch
	elisa-plugins-good = 0.5.23 is needed by elisa-0.5.23-1.fc9.noarch
Comment 49 Silvio Schneider 2009-02-07 11:50:52 EST
this solves the dependendy deadlock:
[root@tower2 Programme]# rpm -Uvh elisa-0.5.23-1.fc9.noarch.rpm elisa-p*

I confirm that I got elisa up and running now on Feroda 10 ! Yeah!

Anyway, the problem on this bugtracker issue should still be solved...please
Comment 50 Matthias Saou 2009-02-17 03:59:21 EST
*** Bug 485863 has been marked as a duplicate of this bug. ***
Comment 51 Matthias Saou 2009-02-19 05:00:01 EST
elisa-plugins-good in now in CVS with a devel package about to be built, and spot has started the review of the elisa-plugins-bad package... we're getting there!
Comment 52 Matthias Saou 2009-03-04 05:26:42 EST
*** Bug 488349 has been marked as a duplicate of this bug. ***
Comment 53 Matthias Saou 2009-03-04 05:50:31 EST
The elisa-plugins-bad package has been reviewed and built for devel a few days ago. Everything is looking good, so I'm rebuilding 0.5.30 for F-9 and F-10 right now. I'll push directly to stable updates, as even if there are problems (which I haven't seen in any of my testing), it can't be any worse than the totally broken packages which are currently available.
Comment 54 Stefan Neufeind 2009-03-08 07:26:20 EDT
I've installed 0.5.30-1.fc10 (all parts) from the koji-builds. Installs fine, starts fine - looks good (and *much* better than the broken 0.3.x). Any chance to get that pushed at least to updates-testing maybe soon?

I was able to play e.g. internet video from TED Talks fine.

On shoutcast however it failed. But maybe that should go into another bug after pushing the 0.5.30 out in the first place?
Comment 55 Stefan Neufeind 2009-03-08 07:38:01 EDT
Just found out that the streaming-audio-problem might be related to a missing elisa-plugins-ugly:
http://elisa.fluendo.com/forums/viewtopic.php?pid=3031
Comment 56 Fedora Update System 2009-03-09 08:26:53 EDT
elisa-plugins-bad-0.5.30-1.fc9,elisa-plugins-good-0.5.30-1.fc9,elisa-0.5.30-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/elisa-plugins-bad-0.5.30-1.fc9,elisa-plugins-good-0.5.30-1.fc9,elisa-0.5.30-1.fc9
Comment 57 Fedora Update System 2009-03-09 08:27:00 EDT
elisa-plugins-bad-0.5.30-1.fc10,elisa-plugins-good-0.5.30-1.fc10,elisa-0.5.30-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/elisa-plugins-bad-0.5.30-1.fc10,elisa-plugins-good-0.5.30-1.fc10,elisa-0.5.30-1.fc10
Comment 58 Fedora Update System 2009-03-09 18:48:06 EDT
elisa-plugins-bad-0.5.30-1.fc9, elisa-plugins-good-0.5.30-1.fc9, elisa-0.5.30-1.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 59 Fedora Update System 2009-03-09 18:54:27 EDT
elisa-plugins-bad-0.5.30-1.fc10, elisa-plugins-good-0.5.30-1.fc10, elisa-0.5.30-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 60 Martin Jürgens 2009-03-09 19:16:38 EDT
Matthias, great. Thanks for your work!

Note You need to log in before you can comment on or make changes to this bug.