Bug 431968

Summary: mixer_applet2 vs. Intel HDA (Alsa mixer): discontinuous muting
Product: [Fedora] Fedora Reporter: Charles R. Anderson <cra>
Component: gnome-appletsAssignee: Ray Strode [halfline] <rstrode>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: low    
Version: 9CC: adebened, bnocera, jonstanley, lpoetter, skarllot
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard: NeedsRetesting
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2009-01-19 12:34:34 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 235705, 431969    

Description Charles R. Anderson 2008-02-07 23:15:29 EST
Description of problem:

Dragging the volume changes the volume, except there are certain points along
the slider where the volume is just entirely muted, including show the little
red 'x' icon next to the speaker icon.  Continuing to drag past these points
returns the volume to the "correct" level for that part of the slider.

Version-Release number of selected component (if applicable):
2.21.4-5.fc9.x86_64

How reproducible:
always

Steps to Reproduce:
1. start playing music in e.g. Rhythmbox
2. play with dragging the volume slider in the panel
3. watch the red 'x' icon appear/disappear occasionally, along with the actual
sound being muted.
4. continue dragging, notice that the volume returns to the previous level.

Additional info:

Lenovo ThinkPad T61 with Intel HDA, snd-hda-intel driver:

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
(rev 03)
        Subsystem: Lenovo ThinkPad T61
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin B routed to IRQ 17
        Region 0: Memory at fe020000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=55mA
PME(D0+,D1-,D2-,D3hot+,D3cold+)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0
Enable-
                Address: 0000000000000000  Data: 0000
        Capabilities: [70] Express (v1) Root Complex Integrated Endpoint, MSI 00
                DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <64ns, L1
<1us
                        ExtTag- RBE- FLReset-
                DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                        RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop+
                        MaxPayload 128 bytes, MaxReadReq 128 bytes
                DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr+ TransPend-
                LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency
L0 <64ns, L1 <1us
                        ClockPM- Suprise- LLActRep- BwNot-
                LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
                        ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
                LnkSta: Speed unknown, Width x0, TrErr- Train- SlotClk-
DLActive- BWMgmt- ABWMgmt-
        Capabilities: [100] Virtual Channel <?>
        Capabilities: [130] Root Complex Link <?>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel
Comment 1 Charles R. Anderson 2008-02-07 23:27:34 EST
Additional detail--this seems to only happen while actually playing music/sound.
 If you aren't playing anything, the muting doesn't happen no matter how much
you drag the slider.

Other interesting effect of this--gnome-volume-control from gnome-media gets
messed up by mixer_applet2.  If you start dragging the mixer_applet2 slider
while gnome-volume-control is open, sometimes the left/right lock on
gnome-volume-control separates.  Then if you try to drag one of the left or
right sliders on gnome-volume-control, it only changes one of the channels until
you click the chain-link icon to lock the left/right channels together again. 
This seems to be very intermittent, so it may take much dragging around to get
it to happen.  None of these problems happen if you just use
gnome-volume-control alone and never touch the mixer_applet2 slider.  I verified
that both applications are set to use the "Intel HDA (Alsa mixer)".  Actually
this effect, might be a gnome-volume-control bug, so I'll clone this bugzilla to
gnome-media.
Comment 2 Charles R. Anderson 2008-04-07 23:07:25 EDT
This is happening on a fresh rawhide install as of 2008-04-07.  This is on a
different system with different hardware--Soundblaster Live! (ADC
Capture/Standard PCM Playback) via DMA.  The symptoms are identical, including
the gnome-volume-control issues.

If I use the volume slider on PulseAudio Volume Control "Output Device" tab, I
have zero issues.  All three sets of sliders move if I drag any of them
(mixer_applet2, gnome-volume-control, pavucontrol), but I have the discontinuous
muting and left/right channel lock issues when using either mixer_applet2 or
gnome-volume-control.

Cc'ing lennart to see if he has any clues...thanks!
Comment 3 Jon Stanley 2008-04-17 00:09:02 EDT
I'm trolling everything that's an F9 blocker - I don't think this one is either,
but I'll leave it on.  I just played videos in totem, played with
gnome-volume-control to my heart's content, and couldn't reproduce a failure.
Hardware here is:

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 02)
Comment 4 Bastien Nocera 2008-04-18 09:52:09 EDT
Please test with the new gstreamer-plugins-base:
http://koji.fedoraproject.org/koji/buildinfo?buildID=46563
Comment 5 Jesse Keating 2008-04-18 11:32:21 EDT
This isn't actually a release blocker, so I'm punting it over to Target.
Comment 6 Charles R. Anderson 2008-04-21 16:42:42 EDT
Things are better now.  There is no longer any discontinuous muting along the
volume slider.  There is still an issue where if you drag the mixer_applet2
slider down to the bottom, it mutes, but then sometimes doesn't unmute when you
drag it back up.
Comment 7 Charles R. Anderson 2008-04-21 16:47:26 EDT
Well, I should have said that things are better on the system with the Intel HDA
sound card.  The system with the SB Live! still exhibits this behavior of
disconinuous muting along the volume slider, although it seems harder to make it
happen.
Comment 8 Bug Zapper 2008-05-14 01:04:18 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bastien Nocera 2009-01-19 11:07:36 EST
*** Bug 431969 has been marked as a duplicate of this bug. ***
Comment 10 Bastien Nocera 2009-01-19 11:07:47 EST
*** Bug 468796 has been marked as a duplicate of this bug. ***
Comment 11 Bastien Nocera 2009-01-19 12:34:34 EST
This bug should be fixed with the new gnome-volume-control and gnome-volume-control-applet in rawhide, available in the gnome-media package. Please reopen if the problem persists with those versions.
Comment 12 Andrew D. 2009-04-02 02:39:48 EDT
Hello, 
I realize this bug has been closed but I just wanted to add that this is present in RHEL 5.3 (its CentOS cousin).

gnome-media-2.16.1-3.el5

I am using a SoundBlaster Extigy USB 

Bus 003 Device 002: ID 041e:3000 Creative Technology, Ltd SoundBlaster Extigy

This started happened right after the upgrade from 5.2 -> 5.3